APS installer patch for ISPConfig available

Discussion in 'General' started by till, Mar 27, 2015.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    We received reports that the APS installer currently fails to update the package list. Our investigation showed that the issue is caused by a malformed XML document that the installer receives from apscatalog.com. The error message that is logged in the ISPConfig system log is "APS crawler: String could not be parsed as XML".

    The patch below improves the APS update script to skip malformed files instead of stopping the whole download process.

    Patch ID: 3054_aps
    Date: 2015-03-27
    Description: This patch fixes: APS crawler: String could not be parsed as XML


    The patch can be installed with the ISPConfig patch installer script.

    Login as root on to your server and run the command:


    The script will ask then for the patch ID, enter:


    and confirm that the patch shall be installed in the next dialog.
    elmacus likes this.

Share This Page