APS Installer Old app versions on new ISPConfig?

Discussion in 'Plugins/Modules/Addons' started by simonb, Apr 26, 2013.

  1. simonb

    simonb New Member

    I just created a new ISPConfig server. I notice that when I update the packages list for the APS installer it shows quite old version of Joomla and Wordpress.

    On a previous ISPConfig server installation I am offered a newer version.
    Ubuntu 10.04.4 LTS (Lucid Lynx)) ISPConfig 3.0.5.1
    Joomla Offered: 3.0.3-5

    On the new server...
    (Ubuntu 12.04.2 LTS (Precise Pangolin)) ISPConfig 3.0.5.2
    Joomla Offered: 1.0.15-7

    This seems a bit backwards. Is there maybe a problem with the APS repository or have I missed something?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The list of aps packages comes from apsstandard.org, so its not our repository. It might be tht they have. Problem with their repo or removed packages.
     
  3. DeCBiT

    DeCBiT New Member

    Very strange because with my installation (Centos 6.4 + ISPConfig 3.0.5.2) it takes Joomla 2.5.11 (Release 5)...
     
  4. simonb

    simonb New Member

    I am also being offered 2.5.11-5. It looks like the repository is slowly catching up with the rest of the world.

    Is there only one repostitory or does ISPConfig pull from a particular mirror of many? Just wondering if we are tuned in to a dud mirror and if it can be changed.
     
  5. simonb

    simonb New Member

    OK. I did some digging around on this. I'm a little bit out of my depth and completely out of time available but it seems the crawler code is missing the newest version of Joomla even though it is clearly in the returned XML from the repository.

    I just submitted a but report.
    http://bugtracker.ispconfig.org/index.php?do=details&task_id=2962
     
  6. monkfish

    monkfish New Member

    Hello,
    For reference on my install.

    --

    Existing CentOS 6.4 x64 build, ISPConfig 3.0.5.2:

    Last package update done some time two weeks ago when installing a wordpress site. Offered joomla 3.0.3-5 when I logged in just now.

    Did APS packagelist update and now offers joomla 2.5.11-5 as well.

    Available packages (175)

    --

    Brand new build done Saturday, same architecture:

    Only offers joomla 2.5.11-5.

    Available packages (159)
     
  7. monkfish

    monkfish New Member

    Again for reference, I have just emptied aps_packages tables and resynced packagelist from within interface;

    existing server above - Available packages (175)
    new server above - Available packages (157)
     
  8. monkfish

    monkfish New Member

    Scrap the above seems the tables didnt empty when I did it.

    Did it again and both old and new servers show 157 packages pulled from repository with joomla 2.5.11-5 offered.

    What I did;
    * rm -rf /usr/local/ispconfig/interface/web/sites/aps_meta_packages/*
    * TRUNCATE "dbispconfig.aps_packages"
    * resync packagelist from interface

    Result = 157 packages offered

    Tested on brand new box just built with no aps packagelist and same results - 157 packages, joomla 2.5.11-5 offered.

    If there's a bugette in the ispconfig code I would suspect its not wiping "old" packages that are not being currently offered.
     
  9. simonb

    simonb New Member

    It seems something changed a few weeks ago that broke some assumptions being made by the APS crawler.

    The 3.0.5.2 Joomla is still offered because it is a newer, not older, version than the 2.5.11.5 found from the repository. My older server also offered both however when I try and create a 3.0.5.2 the next screen in the wizard refers to 2.5.11.5 again.

    Flushing the APS cache directory and the database table and running the crawler again gives only 2.5.11.5.

    Actually the latest version in the repository is 3.1.1-3 if only the APS crawler can be persuaded to see it.

    BTW. Please vote for the bug report if you are also experiencing the App version problem.
    http://bugtracker.ispconfig.org/index.php?do=details&task_id=2962
     
    Last edited: May 22, 2013
  10. monkfish

    monkfish New Member

    How interesting,

    Search repository online at apsstandard.org and you do not even get joomla 2.5.11-5 returned in the list - they have 2.5.11-6 there.

    http://apsstandard.org/applications#searchterm=joomla&addon=false

    Not sure how that translates into a list pulled from apscatalog.com, according to server/lib/classes/aps_base.inc.php.

    OT I seem to recall trying to log a bug report before stating I had duplicate categories in drop-down boxes on the APS filters - caused by difference between upper case and lower case I think.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    We will check that according to your bugreport. Please add any further findingsthat might help us to locate the bug to your bugtracker entry.
     
  12. simonb

    simonb New Member

    Thanks Till. I have found a solution that appears to work for me and submitted a patch in the bug report.
     
  13. monkfish

    monkfish New Member

    Yikes!

    Simon, out of curiosity I just put that patch on one of my dev boxes (Centos 6.4 x86_64 + apache), updated packagelist and about 45 newer packages have dropped in with a couple of new categories as well!

    Thanks from me for looking at that - I look forward to seeing an update rolled into ispconfig.
     
  14. simonb

    simonb New Member

    Great to hear it worked for you!
     

Share This Page