APS Installer, missing after 3.1 -> 3.2 update

Discussion in 'Installation/Configuration' started by ffab, Oct 30, 2020.

  1. ffab

    ffab New Member

    Hi,
    I runned for couple of days now, the 3.2 update, of ISPConfig. All was fine (previous version 3.1.15p3), my mono server installation is ok.
    But now in websites, i don't see the APS section anymore.
    Maybe this is related : in System section, Applications & Plugin the http://repo.ispconfig.org/addons/
    is active, but the list does not refresh at all.

    Has anyone had the same problem ? Any hints for solving appreciated,
    Thanks,
     
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    As noted in the release notes (https://www.ispconfig.org/blog/ispconfig-3-2-released/), we removed APS from ISPConfig because the project is dead.

    The System -> Applications & Plugin section is not related.

    It is possible to re-enable APS, by changing a setting in the database (in the table sys_ini -> config, change show_aps_menu=n to show_aps_menu=y). In 3.2.1, we will add a option to the UI where you can re-enable it. But APS will be completely removed in a future release.

    See https://git.ispconfig.org/ispconfig/ispconfig3/-/issues/5676 aswell.
     
    gilson, ffab and elmacus like this.
  3. ffab

    ffab New Member

    Hi Th0m,
    thanks for the answer, seems i did'nt read the released notes carefully...
    I was able, according to your instructions to re-enable the APS section, by adding the config parameters !
    This will let some time to warn users before this feature disapear.

    Regards,
    Fabrice
     
  4. gilson

    gilson Member


    Thank my dear... work! but how will we install for example wordpress and etc? thank
     
  5. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    See the APS menu. If there are no packages available, it is not possible. The repo to retrieve them from is dead.
     
  6. gilson

    gilson Member

    I got it, but I say: in the future how should we install packages like wordpress... thank.
     
  7. gilson

    gilson Member

    Th0m, I have been using ISP for 2 years and install using google cloud vps, but I have never had this error - NGINX failed not start... (image attachment) on a new install... but now it is giving this problem... do you know how to solve? thank.
     

    Attached Files:

  8. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    We are planning to create our own installer, but I can't make any promises. Without that, you will have to install it manually.

    I don't use nginx myself so I'm not sure, however, when looking up your error, I found this: https://stackoverflow.com/questions...-server-names-hash-you-should-increase-server
     

Share This Page