APS installer Installation_error

Discussion in 'General' started by CrypticDesigns, Apr 15, 2015.

  1. Hello,

    First of all I would like to say that I really like the ISPconfig control panel. Its one of the best control panels on the market right now and all open source.

    Now I got a problem with the APS installer. I would love to use this installer so it all goes a bit faster and easier for my clients and myself. However when I install a package fomr the APS Installer menu in sites it gives me an installation_error. Not the xml error, I patched it, but I can see it creates a DB and a DB user. However I don't see it downloads any file in the webserver for the actual website. I am trying to install a Wordpress package, don't see any logs in the System-Log. Where should I look for a log about this issue? Or how could I find the problem?

    Thanks for reading
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Hey till,
    Thank you for your answer. The installer works now. Nice job on the whole ISPconfig panel!
     
  4. Freiheit

    Freiheit New Member

  5. Freiheit

    Freiheit New Member

    Hello again,

    It seems that APS intaller works with wordpress, but not with magento.
    there are some others that also don't work
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, it is known that not all packages from apsstandard.org are working. Especially the more complex ones like magento might fail.
     
  7. Freiheit

    Freiheit New Member

    So, i have to install it manually then?

    Thanks for the quick answer!
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    yes.
     
  9. Freiheit

    Freiheit New Member

    thanks again!
     
  10. Freiheit

    Freiheit New Member

    BTW, for the little bit I looked into this, log files and such, it appears to be a permissions issue.
    One of the errors was that the access to a folder was denied.
    Maybe adding ispconfig (user) to the www group?
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    The installer is not run as ispconfig user. Please post the error message that you got.
     
  12. Freiheit

    Freiheit New Member

    I don't have the log anymore. But it said something about it not having write permissions on some folders
     

Share This Page