aps Installation_error

Discussion in 'General' started by almere, Nov 27, 2012.

  1. almere

    almere HowtoForge Supporter

    I tried to install Magento, Modx with APS installer (ISPConfig 3.0.5), but i get "Installation_error", while site is installed and working normally.

    With joomla, wp its going wel. I checked, what php libraries does it need, and i have all of them installed.

    Any suggestions about it?

    Thanks
     
  2. webguyz

    webguyz HowtoForge Supporter

    Running into problems trying to install apps as well.

    Is there a Dummies Guide for how to use APS in ispConfig 3.0.5? I went to APS Standard website and most of the Docs seem geared toward implementing it.

    When I go to install the app it asks which directory to put it in. Does the directory have to exist? Or will it create the directory like other installers like Softaculous do?

    Does it create the DB if needed for example for WP?

    Where is a log we can look at to determine why the install failed? Have yet to get one app installed. Can't seem to delete a failed install as well. Not sure if we can retry the installation, seems I was getting an error telling me package was already installed.

    Thanks!
     
  3. almere

    almere HowtoForge Supporter

    When I go to install the app it asks which directory to put it in. Does the directory have to exist? Or will it create the directory like other installers like Softaculous do? - it makes directory.

    Does it create the DB if needed for example for WP? - yes
     
  4. webguyz

    webguyz HowtoForge Supporter

    How do I remove a failed installation of the APS. I see a Installation_remove at the top of the screen when I click the red circle and acknowledge I want to delete it, but it does not remove it.

    Thanks!
     
  5. almere

    almere HowtoForge Supporter

    I also have that problem. I do it with FTP.
     
  6. till

    till Super Moderator

    You are using a beta and not a final software. Beta software is for testing only and it has bugs. Please see bugtracker, there is a open bug listed that describes that deleting of apps does not work in the beta.
     
  7. almere

    almere HowtoForge Supporter

    Till,

    My post was about installing.
     
  8. till

    till Super Moderator

    And i was answering webguyz post #4.

    Regarding your first post, the normal debug function can be used for this as well. They re described in he faq.
     
  9. webguyz

    webguyz HowtoForge Supporter

    I was able to install WP and Zencart using APS, but Joomla still fails and thats what I was using as my initial test and getting frustrated. But after seeing the other apps install I at least know its working and there is just something wrong with that Joomla installer.

    Would be great if there was a visual que for status for installation_task like a graphic that was constantly in motion. Same for when it s completed, a green check box and a red one if the install failed.

    Good job ispConfig team! Getting more impressed every day.
     
  10. till

    till Super Moderator

    A visual feedback during installation is not possible as all actions are processed asyncroniously as batch job.
     
  11. abdi

    abdi New Member

    Joomla Installation Issues

    Till,

    I have come to realize that when Joomla is installed then a password protected folder is created for /administrator however the actual protected folder user is NOT activated despite being created in the database.

    Endlessly you get 500 error when accessing /administrator till a protected folder is deleted.

    Is this my own experience or there are others with the same problem?

    Joseph
     
  12. till

    till Super Moderator

    This protection is part of the joomla package from apsstandard.org and not from ispconfig, so it is not visible in the ispconfig database. We have no influence on the content of packages from apsstandard.org or what they create in detail in a website.
     

Share This Page