Apps Installation in ISPConfig 3

Discussion in 'ISPConfig 3 Priority Support' started by Quaxth, Oct 29, 2013.

  1. Quaxth

    Quaxth New Member

    Started to test to install several Applications using the Application Installer of ISPConfig and must say that most are failing in some point.

    10 installation tried and only 1 get success to really work, means 99% because the Admin account is missing. That apps is Magento. All other Apps just giving an Server 500 Error if installation were complete or even the installation failed.

    Ok, that maybe could be of an problem with my Modem/Router, which will be changed tomorrow because of ongoing FTP problems. And both my Server with ISPConfig and the desktop I use for to install the apps are on the Modem/Router's internal 1Gb/s switch and therefore it's possible that the failed installations are triggered from that device. That I'll know tomorrow after the change of that device.

    Nevertheless the amount of failed installation is just to high.

    Regarding Magento install, I could not find the logon for admin in that standard installation. There is the sign up windows for new user and a normal logon windows but that didn't work with username and password given by installation nor with the admin e-mail address. So, I'm really don't know the installation were complete or not.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    A 500 error does not nescessarily mean that the app installation failed, it means that the app can not run e.g. because a global setting in your php.ini is not correct. Check the error.log of the website.
     
  3. Quaxth

    Quaxth New Member

    For CS-Cart the error log shows:
    while for BigAce:
    That means that in both installation FatsCGI is in error, if I understand that right.

    What could be done?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This means that php dies for some reason, this can be php settings or a incompatibility of the app with a specific php version or something similar. If you cahnged any flder permissions in that site, then this can cause such a error as well. You can try to enable in php.ini to show errors on the screen and then restart apache.
     
  5. Quaxth

    Quaxth New Member

    Thanks Till.

    I plan the following changes in php.ini located at: /etc/php5/apache2/:

    would be such changes OK?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, thats ok.
     
  7. Quaxth

    Quaxth New Member

    Thanks Till will do that. Will also keep the original file as backup.

    Still waiting for the ISP Guy top come, should between 10-12 and now it's already 15:00!! Anyway, that's Thai style!!

    Let you know what happen after the file change.
     
  8. Quaxth

    Quaxth New Member

    Ok, after change settings in php.ini, still the same errors, no changes!!

    Also NO error messages displayed.

    What else could be done?

    Thanks.
     
  9. Quaxth

    Quaxth New Member

    Error messages now on Server Monitor:

    That error messages is displayed many times now and all time the exact same.

    What I could do?

    Thanks.
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you change any folder permissions in a subfolder of /var/www manually?
     
  11. Quaxth

    Quaxth New Member

    NO, I don't! Everything as installed, nothing changed!

    Was only try to start the apps: IMPOSSIBLE, except Magento. That was the only Apps I installed which works. Also found the Admin Panel in meantime. So that's the only working installation!

    Most of the install try's were abandoned before the end and classified as failed.

    Thanks.

    Edit:

    Just a question: Is it possible that an unsuccessful Permisson change could have that effect?

    I ask because I was try to install some Script manually but couldn't because I was not able to the Directory created. So I was try to change the folder permission with NO success. Now I'm confuse and don't know that could have triggered tha problem?!

    Is there any way to set back the permissions to default?
     
    Last edited: Oct 30, 2013
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Delete the website in ispconfig and recreate it.

    Maybe you tried to upload files into a wrong folder. The files have to be uploaded into the "web" folder of the site. the web folder is owned by the ftp user, so it has always write permissions to that folder.

    Regarding the php issues, try to create a simple php fle with phpinfo() command:

    <?php
    phpinfo();
    ?>

    upload it by ftp into the web folder and open this in the browser. Does it work or do you get an error too?
     
  13. Quaxth

    Quaxth New Member

    Sorry Till, FTP isn't working!! OK, used my laptop with 3G. Uploaded that file as xyz.php to the/web folder and get an Error 404 Not Found.
     
  14. Quaxth

    Quaxth New Member

    Will try that later.



    No, the folder I uploaded too were correct.

    Get 404 Not Found Error!
     
  15. Quaxth

    Quaxth New Member

    Question: If I delete a website in ISPConfig, will the whole content of that website delete as well? Or will the content still inside the /web folder?

    Thanks.
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    When you delete a site then this will delete all files and folders that belong to this website.
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Then the file is either uploaded to a wrong location or the url that you use to access the file in the browser is wrong or a .htaccess file in this website redirects the request to a wrong location or the domain that you use to access the site does not point in dns to the correct IP.
     
  18. Quaxth

    Quaxth New Member

    OK, just delete some already and will install tomorrow in thr morning and what happen than. For me the day is over now, have wake up 5am!!

    Thanks a lot Till, will see tomorrow how it goes from there.

    Good night.
     

Share This Page