Apps Apache vhost

Discussion in 'Developers' Forum' started by Croydon, Jun 19, 2010.

  1. Croydon

    Croydon Member Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    The current apache ispc apps vhost looks like this:

    Code:
    ######################################################
    # This virtual host contains the configuration
    # for the ISPConfig apps vhost
    ######################################################
    
     Listen 8081
    # NameVirtualHost *:8081
    
    <VirtualHost _default_:8081>
      ServerAdmin webmaster@localhost
    
    
      <IfModule mod_fcgid.c>
        DocumentRoot /var/www/apps
        SuexecUserGroup ispapps ispapps
        <Directory /var/www/apps>
          Options Indexes FollowSymLinks MultiViews +ExecCGI
          AllowOverride AuthConfig Indexes Limit Options FileInfo
          AddHandler fcgid-script .php
          FCGIWrapper /var/www/php-fcgi-scripts/apps/.php-fcgi-starter .php
          Order allow,deny
          Allow from all
        </Directory>
      </IfModule>
    
      <IfModule mod_php5.c>
        DocumentRoot /var/www/apps
        AddType application/x-httpd-php .php
        <Directory /var/www/apps>
          Options FollowSymLinks
          AllowOverride None
          Order allow,deny
          Allow from all
        </Directory>
      </IfModule>
    
      ServerSignature Off
    
    </VirtualHost>
    Because I found it useful I set up a repository and installed phpmyadmin with the ispconfig3 package manager and a simple setup.sh script.
    As expected the package was installed as user ispapps in /var/www/apps/phpmyadmin

    The problem is that I get a 403 when accessing any php file there.
    If i comment out one of the parts in the vhost file (fcgid or modphp) it works like charm but if both sections are in there - 403 all the time.

    Is there a bug in the vhost template for the apps?
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Which Linux distribution do you use? I dont experience that problem on my debian system.
     
  3. Croydon

    Croydon Member Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    It's a debian lenny 5.0.4 with apache 2.2.9-10+lenny7
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Ok. I've added it to the bugtracker.
     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    I tested it again on a new debian setup and the apps vhost works for me. Which is the exact error message that you get in the apache error log file for the 403 error?
     
  6. Croydon

    Croydon Member Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    There is no entry in the error log (only for missing favicon).
    Just a 403 error in the browser.

    Forbidden

    You don't have permission to access /phpmyadmin/index.php on this server.


    Access log is not enabled, i enabled it for testing in the app vhost but shows only 403 - no more info.


    edit: access log entry:
    xx.xx.xx.xx - - [22/Jun/2010:19:25:05 +0200] "GET /phpmyadmin/ HTTP/1.1" 403 193 "-" "Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.1.9) Gecko/20100501 Iceweasel/3.5.9 (like Firefox/3.5.9)"

    edit 2: if i do a "a2dismod fcgid" and restart apache it works again, as soon as i a2enmod fcgid -> same as before: 403 - so if one is disabled either in vhost or in apache modules it works - as soon both are enabled in modules and in vhost - error 403
     
    Last edited: Jun 22, 2010
  7. Horfic

    Horfic Member

    I got the same problem, regarding my apps. I can access all files except php.

    Its a fresh Debian Lenny installation with ISPConfig latest trunk version.
     

Share This Page