apostrophe problem

Discussion in 'Installation/Configuration' started by MisterRichard, Oct 23, 2012.

  1. MisterRichard

    MisterRichard New Member

    Hi,

    I have recently upgraded a debian server from 5.0 to 6.0 and also upgraded ISPConfig to version 3.0.46.

    Since then I have notice I am unable to use apostrophe's (') when inserting into a mysql database.

    I am expecting I have overwritten a PHP config file inadvertently, as apostrophes were working before this.

    Any clues ?

    Mister Richard.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Where do you get the error? In phpMyAdmin? What's the exact error message?
     
  3. MisterRichard

    MisterRichard New Member

    Hi Falko,

    It's another CMS on the same box as ISPconfig that uses PHP and mysql, this error has only happened recently when editing any posts, I discovered the error only happens when there are apostrophes on the data being inserted.

    'Error editing page: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'left'/>'

    Cheers,

    Richard
     
  4. MisterRichard

    MisterRichard New Member

    THis error is showing up when trying to submit the data inside the CMS.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Open your php.ini and check the values of magic_quotes_gpc, magic_quotes_runtime, and magic_quotes_sybase. they shold all be off, I guess.
     

Share This Page