Api method mail_user_add is not crating the mailbox

Discussion in 'Developers' Forum' started by vinod.linux, Apr 30, 2012.

  1. vinod.linux

    vinod.linux New Member

    I am using ispconfig remoting api in order to create new mailbox user.
    I have tried mail_user_add api method. Its returning a sucess method and details are saved in mail_user table. But there is no folder created under /var/vmail/email.biz folder.

    I know that it creates the folder when it receives the mail. I tried to send mail to newly created user "[email protected]".

    Log file says

    temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/email.biz/hmmnoe/21182.0.gsmtp.email.biz. )

    Now i am unable figure out wass the exact problem is.Any help will be highly appreciated
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. vinod.linux

    vinod.linux New Member

    Yes i was passing wrong path for maildir. I modified it with correct one. Now directories are created even i can access the welcome mail but when i tried to send email to newly created mailbox i got following error

    Apr 30 20:39:07 dianin postfix/smtpd[12659]: NOQUEUE: reject: RCPT from localhost[]: 554 5.1.1 <[email protected]>: Recipient address rejected: User unknown in virtual mailbox table; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<www.email.biz>
    Apr 30 20:39:07 dianin postfix/smtpd[12659]: disconnect from localhost[]
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Are the email and login field of the mail_user table filled in corrcty of the user that you created? Compare it with a user that you created in the ispconfig interface.
  5. vinod.linux

    vinod.linux New Member

    Its working now

    Yes the problem was in one field, postfix field in user_data table was set to 'n' , i changed it into 'y' its working fine now.
    Thanks Till

Share This Page