APF Advanced Policy Firewall under vps probs

Discussion in 'Technical' started by robsbots, Nov 18, 2011.

  1. robsbots

    robsbots New Member

    Hi all.

    I'm hoping to pick somebody's brain. I am trying to install APF on a ubuntu karmic vps. I do not have access to the real server, just the vps.

    I have :-
    set in the config file which I belive is correct BUT when I start the server it says
    apf(31804): {glob} flushing & zeroing chain policies
    apf(31804): {glob} firewall offline
    apf(31839): {glob} activating firewall
    apf(31879): {glob} determined (IFACE_IN) venet0 has address
    apf(31879): {glob} determined (IFACE_OUT) venet0 has address
    apf(31879): {glob} loading preroute.rules
    venet0 has address ???

    Should this not be my static public ip address for the server ?
    APF continues to load and all looks good except I can now no longer access the website. I seem to be able to ssh to the server ok.
    # ip addr gives
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet scope host lo
        inet6 ::1/128 scope host
           valid_lft forever preferred_lft forever
    3: venet0: <BROADCAST,POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
        inet scope host venet0
        inet my.stat.ic.ip/32 scope global venet0:0
    I have also tried IFACE_IN="venet0:0" which reports
    could not verify that interface venet0:0 is routed to a network, aborting.

    Is it my IFACE settings or should I be looking at my rules ?

    I still have the "DEVEL_MODE="1" safety net out and the web page pops up after the time out.

    Any help would be much appreciated.


    Last edited: Nov 19, 2011
  2. robsbots

    robsbots New Member

    Prob sorted

    It took a while but have now sorted out the problem. It was a typo in the config file.


Share This Page