Apache's not running (failed)

Discussion in 'Installation/Configuration' started by webking, Oct 18, 2007.

  1. webking

    webking New Member

    [[email protected] httpd]# /etc/init.d/ispconfig_server start
    Starting ISPConfig system...
    fopen: No such file or directory
    ispconfig_httpd: could not open document config file /root/ispconfig/httpd/conf/httpd.conf
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    Could not open input file: /root/ispconfig/scripts/shell/firewall.php
    FreshClam is already running!
    ISPConfig system is now up and running!


    [[email protected] html]# /etc/init.d/httpd restart
    Stopping httpd: [FAILED]
    Starting httpd: [FAILED]
    [[email protected] html]# /etc/init.d/httpd stop
    Stopping httpd: [FAILED]
    [[email protected] html]# /etc/init.d/httpd start
    Starting httpd: [FAILED]
    [[email protected] html]#

    Can someone explains or where to look for error? The logs /var/logs/httpd.. is empty.
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Can it be possible, that you installation of ISPConfig is broken?

    fopen: No such file or directory <--- any file is missing (not a normal error)
    could not open document config file /root/ispconfig/httpd/conf/httpd.conf (httpd conf is MISSING)
    Could not open input file: /root/ispconfig/scripts/shell/firewall.php Firewallscript is missing as well.....

    How did this error occur? I mean what did you change, sth. like this does not happen all of a sudden.
  3. webking

    webking New Member

    Dont know

    It s a fresh installation.

    After I see the ISPConfig is successfully complete message, I tried to pull the ip address but not working so I tried to restart apache but none is working.

    I think it breaks something during the installation, It went pretty fast w/out prompting for database/ssl or anything like that.

    I'll have to run it again.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    ls -la /root/ispconfig/

Share This Page