Apache2.x/openSuse 10.2 Webalizer

Discussion in 'Installation/Configuration' started by pinky, Jan 24, 2008.

  1. pinky

    pinky New Member

    Hi All,

    I have a prob running the webalizer stats, I've searched through the forums pretty extensively over the last few days for a solution and have tried all the proposed possible solutions.

    We have ISPConfig running on openSuse conf'd as below:
    - Apache generate to /var/log/httpd/access.log, tried apache2/access.log also
    - ISPConfig is conf'd to use that log path in the settings in the web-admin

    From what I saw looking at ISPConfig's logs.php its looking for
    - /var/logs/httpd/access_log_[DATE]

    Since this log isn't being created, logs.php in the cron isn't creating individual web.log and therefore webalizer is sitting around taking a nap :)

    Apache isn't generating this, are my log settings setup wrong for ISPConfig? Is this an Apache conf issue or an ISPConfig conf issue?

    Thanks - ISPConfig is great and I'm 99% to getting it running smoothly, this is one of the last issues hanging around driving me slowly crazy.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that you have the following line in your apache2.conf file:

    Code:
    LogFormat "%v||||%b||||%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
    CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig
    It is inserted by ISPConfig automatically, maybe a update with yyast removed it from your configuration.
     
  3. pinky

    pinky New Member

    Thanks, that looks like what I was expecting - was pretty sure it had to be an apache conf issue. I've changed the conf and I guess it's just a wait and see if the stats are generated after midnight tonight. The log files have been created and sym linked ok so far.

    The server was preloaded with a LAMP setup which we ripped out and rebuilt from source before putting in ISPConfig. I guess somewhere the log setup got lost!
     
  4. pinky

    pinky New Member

    Yup, that did it - Thanks.
     

Share This Page