Apache2 trouble after install

Discussion in 'Installation/Configuration' started by cbakken, Mar 23, 2006.

  1. cbakken

    cbakken New Member

    Hi,
    I finally managed to install ISPConfig on SLES9 SP3 aided by various helpful posts in this forum.
    After a server restart I now have problems with Apache2, it won't start!
    httpd2 -k start gives me the following error msg:
    -------------------
    httpd2: could not open document config file /etc/apache2/vhosts/Vhosts_ispconfig.conf
    -------------------

    permissions are:
    -rwxr-xr-x 1 root root 2033 2006-03-23 03:26 Vhosts_ispconfig.conf

    I've tried to chown it to wwwrun:www and chmod 777, but the same error appears.

    Any idea, anyone?
     
  2. cbakken

    cbakken New Member

    Fixed! But another problem found.....

    It was Novell's AppArmor that denied access to the file.
    I disabled AppArmor, and now I can start Apache2.

    But there's another problem:

    I have added a site with MySQL database via ISPConfig.
    When I open a shell and write <mysql -D web1_db1> I get an error stating that this database doesn't exist!

    I need to import a database from another server into this database.

    Thanks for any help.
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Run
    Code:
    mysql -u root -p
    SHOW DATABASES;
    quit;
    to find out which databases exist (or use phpMyAdmin to check).
     
  4. cbakken

    cbakken New Member

    Fixed!

    I had forgotten to give the MySQL user (which ISPConfig logs in as) GRANT rights. I then had to reload and restart mysqld.
     

Share This Page