Apache2 Not Upgrading on Debian

Discussion in 'Installation/Configuration' started by Paynter, Mar 30, 2012.

  1. Paynter

    Paynter New Member

    So, interestingly enough, for the past few months, apt-get has been successfully upgrading all of my software, except for Apache2. I have tried just about everything, but Apache2 just does not want to upgrade. I'm stuck on version 2.2.16.

    Here's what I've tried:

    apt-get update
    apt-get upgrade (or) apt-get upgrade install apache2 (or) apt-get upgrade install (or) apt-get install apache2
    Now, either two things will happen. Either I'm told that Apache is already up to date, or that the upgrade was installed successfully. Of course, after every apache upgrade, I restart it using:

    /etc/init.d/apache2 restart
    and everything seems to go as planned, until I run:

    root:/# apache2 -v
    Server version: Apache/2.2.16 (Debian)
    Server built:   Feb  5 2012 21:01:59
    I'm confused as all hell. Why is all other software upgrading just fine, but Apache2 is stuck on version 2.2.16, even after restarting the server, etc?

    Any suggestions would be immensely appreciated :)
  2. erosbk

    erosbk New Member

    As I could see, you have lastest version of Apache2 available for Debian 6. Debian only have stable/tested version of programs, commonly, debian is not up to date as other distros are, like ubuntu for example...

    See Debian doc to understand how Debian project works.

    This is the info with apache2 -v in my server:

    Server version: Apache/2.2.16 (Debian)
    Server built: Feb 5 2012 21:35:42

Share This Page