Apache2 in not listening in port 80

Discussion in 'ISPConfig 3 Priority Support' started by Galopete, Nov 15, 2018.

  1. Galopete

    Galopete New Member HowtoForge Supporter

    Hello to all
    I was made a personal server using Ubuntu 18.04 and Perfect Server tutorial, but i have a problem with apache2, it is not listening on port 80 but on 8080 (Ispconfig port) yes, and it works.
    This is netstat exit of my server:
    terminal.png
    When i call my server in firefox in the server box Apache answer fine in port 80 but no from outside computers.
    I have my server behind a NAT router, but i have the NAT rules with 80 port configured, and i tryied to disable server's firewall with no luck.
    Any idea?
    Many thanks.
    Abraham
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Looks like apache is listening only on TCP/IP version 6 port.
    How have you set up v4 and v6?
     
  3. Galopete

    Galopete New Member HowtoForge Supporter

    Thank you for your answer, Taleman.
    I was follow the Perfect Server guide, by default the guide configures Apache to listen in port 80, and i do not change any configuration in apache config files.
    In fact using the web browser in the server, i can access my test web page via port 80, but no from outside computers.
    Abraham
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess you might have closed port 80 in a firewall/router or you use an ISP that does not allow connections on port 80 incoming to your server.
     
  5. Galopete

    Galopete New Member HowtoForge Supporter

    Hello Till, thanks for your answer.
    I have my router properly configured in the port forwarding setup, 80 open and redirected to internal ip off the server.
    The firewall in the server disabled.
    And my ISP doesn’t block any port, (i have a NAS in the same network, and i can access it from outside my network vía http in port 80.
    I was installed another server testing in my network and i can access it via 80 port...
    I,m sure that is a os problem, but i cannot find the solution...
    Abraham .
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    According to netstat output, apache listens on port 80, so it must be reachable there. The test to access apache was performed from within your network by entering the internal IP address into your browser? If not, then test it like that.
     
  7. Galopete

    Galopete New Member HowtoForge Supporter

    Till, if i try to access to my server within my network from another computer using internal IP (192.168.100.23) of the server, it works but show me the Ubuntu default page for Apache test...
    If i try to access to the server whitin my network using fqdn (galoserver.org)... it works but show me the "Welcome" page generate by Ispconfig... i don't understand...
    If i try to access outside my home network to my server it doesn't work...
     
  8. Galopete

    Galopete New Member HowtoForge Supporter

    I found the problem... the port forwarding of my router is not working properly... i had to configure the rules and i had to reboot the router, now Apache works outside my network as spected in all ports.
    Thank you very much for your interest in my problem, Till.
     

Share This Page