Apache2 error after update to 3.0.5.4p3

Discussion in 'ISPConfig 3 Priority Support' started by 3arh, Aug 18, 2014.

  1. 3arh

    3arh New Member HowtoForge Supporter

    Hi ,
    I get errors with starting Apache after update from 3.0.5.3 to 3.0.5.4p3,


    [Mon Aug 18 12:38:32 2014] [warn] VirtualHost 91.185.195.131:80 overlaps with VirtualHost 91.185.195.131:80, the first has precedence, perhaps you need a NameVirtualHost directive

    [Mon Aug 18 12:38:32 2014] [warn] NameVirtualHost *:8082 has no VirtualHosts
    [Mon Aug 18 12:38:32 2014] [warn] NameVirtualHost *:8080 has no VirtualHosts
    [Mon Aug 18 12:38:32 2014] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Mon Aug 18 12:38:32 2014] [warn] NameVirtualHost *:8082 has no VirtualHosts
    [Mon Aug 18 12:38:32 2014] [warn] NameVirtualHost *:8080 has no VirtualHosts
    [Mon Aug 18 12:38:32 2014] [warn] NameVirtualHost *:80 has no VirtualHosts
    [Mon Aug 18 12:38:32 2014] [warn] NameVirtualHost *:443 has no VirtualHosts
    (98)Address already in use: make_sock: could not bind to address [::]:80
    (98)Address already in use: make_sock: could not bind to address [::]:8080
    (98)Address already in use: make_sock: could not bind to address [::]:443

    maybe I screw up , becouse I updated some slave (2) servers before master , I also did get Apache2 error on a slave server , but it was just missing NameVirtualHost directive, whitch I added to vhost files.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The Namevirtualhost messages are ok. The "make_sock: could not bind to address" arereal errors, they can have 2 reasons:

    a) There is already an apache instance listening on these ports, e.g. a hanging process.
    b) your apache config contains somewhere duplicate "Listen Statements.

    For a) Stop apache, then check will "ps aux" that there are really no apache processes left. If there are processes, kill them with "kill" command and then check with "netstat -ntap" that port 8080, 8082 and 443 are free now then start apache again.

    For b) Check with:

    grep -r Listen /etc/apache2

    for duplicate listen statements.
     
  3. 3arh

    3arh New Member HowtoForge Supporter

    With grep -r /etc/apache2 I get this:

    /etc/apache2/ports.conf:Listen 80
    /etc/apache2/ports.conf:Listen 8080
    /etc/apache2/ports.conf:Listen 443
    /etc/apache2/sites-enabled/ispconfig.vhost:#Listen 8080
    /etc/apache2/sites-enabled/000-apps.vhost: Listen 8081
    /etc/apache2/sites-enabled/000-ispconfig.vhost:#Listen 8080
    /etc/apache2/sites-enabled/000-ispconfigmonitorappnonssl.vhost:Listen 8082
    /etc/apache2/sites-available/ispconfig.vhost:#Listen 8080
    /etc/apache2/sites-available/apps.vhost: Listen 8081
    /etc/apache2/sites-available/ispconfigmonitorappnonssl.vhost:Listen 8082

    I don't see any duplicate statements... and there is not anything running on port 80, 8080, 443. Is there anything else that could triggered the error or is it just wrong listed in ports.conf.

    Best regards.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This looks fine except of the two ispconfig vhost entries in sites-enabled:

    /etc/apache2/sites-enabled/ispconfig.vhost
    /etc/apache2/sites-enabled/000-ispconfig.vhost

    please run:

    rm -f /etc/apache2/sites-enabled/ispconfig.vhost

    and try to start / restart apache again.
     
  5. 3arh

    3arh New Member HowtoForge Supporter

    Thank you, I will try this in the evening again, best regards.
     

Share This Page