Apache2 & Error 403 / 404

Discussion in 'Server Operation' started by Zombie, Oct 17, 2007.

  1. Zombie

    Zombie New Member

    Apache2 & Error 403 / 404 (Resolved)

    I just installed apache2, configured everything - from what I can tell, correctly, because I can get web pages to display on the server machine and on other computers on my network and over the internet. That is if the html or php file was created within my /home/www folder.

    However, I am running into the 403 / 404 errors when I try to drag and drop the files from a web site that I have been working on.

    I have also tried the sudo cp command to copy the files from one folder into the www folder, still with no luck. Somehow I was able, "got lucky", I extracted the files from a zip directly into the www folder and everything worked, I have no idea what I did differently, but on other attempts of doing the same thing, I have not had the same outcome.

    Other info: Ubuntu Feisty Fawn, installed via downloading the "lamp" package.

    I'm puzzled, I'm not a computer noob, but I am a linux noob, so any and all help would be much appreciated!!


    ------- Resolved --------

    I had to change the permissions on the folder, and on the individual files that I had dragged into my www folder. I did a Ctrl-A, right clicked on one of the files, went to the permissions tab and changed the file access setting under the "Group:" & "Others:" section to read only. Reloaded my browser and bang there was my web site!!
    Last edited: Oct 18, 2007

Share This Page