Apache2 Directory permissions issues

Discussion in 'Installation/Configuration' started by knotpc, May 30, 2008.

  1. knotpc

    knotpc New Member


    I am using ISPCONFIG on Debain. I used the how to to install. I also installed wordpress from wordpress.org. I am having issues uploading files from the PHP web pages. The directory that I am loading to has the owner set to www-data:www-data, with 0777 for permissions. I have restarted the httpd server. rebooted the server everything. I still get the message below.

    "Unable to create directory /var/www/web2/web/Images/2008/05. Is its parent directory writable by the server?"

    Starting at /Images/ the folder permissions are set to www-data:www-data 777. I have also tried setting the permissions to web2_admin:web2, but that is not a valid apache user so of course it does not work.

    any ideas on this would be appreciated.
  2. Leszek

    Leszek Member

    Does this website account have an administrator ?
    I mean when You choose a website (or add one), go to "User & Email" and choose a user (or add one) and tick "Administrator".
    Last edited: May 30, 2008

Share This Page