Apache2 : AH00526: Syntax error on line x

Discussion in 'Installation/Configuration' started by MaamuT, Feb 11, 2015.

  1. MaamuT

    MaamuT Member

    Hi all,

    Sorry for my funny english, i'm french and i don't speak very well…

    I have a small problem with Apache2 when it restart (when typing service apache2 restart or make change in ispconfig interface).

    Reason for Apache restart failure:  * Restarting web server apache2
    * The apache2 configtest failed.
    Output of config test was:
    AH00526: Syntax error on line 6 of /etc/apache2/sites-enabled/100-domain.tld.vhost:
    The address or port is invalid
    Action 'configtest' failed.
    The Apache error log may have more information.
    Apache did not restart after the configuration change for website domain.tld. Reverting the configuration. Saved non-working config as /etc/apache2/sites-available/domain.tld.vhost.err
    Onto original file, the virtualhost directive is : <VirtualHost *:80> but after Apache restart : <VirtualHost :80> he lost the wildcard * !

    I don't understand any…

    No emergency, it's just warnings alert, but… i like clean log files ;)

    Ubuntu server 14.04.02 LTS, Ispconfig, Apache 2.4.7, PHP 5.5.9, MySQL 5.5.41…
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check if the ip addesss field of this website is empty in the database (table web_domain).
  3. MaamuT

    MaamuT Member

    Hi Til,

    Yes, the field is empty.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Check that the option "Activate IP address wildcard (*)" is enabled under System > server config > web. then go to the settings of that website, select * in the ip address field and press save.
  5. MaamuT

    MaamuT Member


    I watch and i will keep you posted…

  6. MaamuT

    MaamuT Member

    Well, problem solved.

    Thx Till, good job ;)

Share This Page