Apache Won't Start

Discussion in 'ISPConfig 3 Priority Support' started by Bob Hall, Apr 9, 2019.

  1. Bob Hall

    Bob Hall New Member HowtoForge Supporter

    Hi There;
    I'm not sure what happened - but apache hunt and then when i tried to restart it, it fails. it complains about an ssl certificate but i do not have one. I was however trying to figure out how to create the file needed to request one from a provider. the last few lines of the apache error log file is attached.
    Please help!

    [Mon Apr 08 19:06:10.812844 2019] [ssl:warn] [pid 20776] AH01909: cipoweb.cipo.ca:8080:0 server certificate does NOT include an ID which matches the server name
    [Mon Apr 08 19:06:10.813001 2019] [ssl:error] [pid 20776] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [subject: O=Internet Widgits Pty Ltd,ST=Some-State,C=AU / issuer: O=Internet Widgits Pty Ltd,ST=Some-State,C=AU / serial: FBB94E380E849C62 / notbefore: Apr 26 16:23:08 2018 GMT / notafter: Apr 23 16:23:08 2028 GMT]
    [Mon Apr 08 19:06:10.813014 2019] [ssl:error] [pid 20776] AH02604: Unable to configure certificate cipoweb.cipo.ca:8080:0 for stapling
    "error.log" 384L, 58103C
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Probably something went wrong with the creation of the self signed ssl certificate that you attempted and this blocks apache now. Try to go to the folder /etc/apache2/sites-enabled/ and delete the file which contains the domain name in the filename of the site where you attempted to create that certificate, then restart apache. If it works now, try to disable the ssl checkbox of that site in ispconfig and save, this should enable the site again without https.
     
  3. Bob Hall

    Bob Hall New Member HowtoForge Supporter

    thank you!
    that worked perfect, sorry for the slow response!
     

Share This Page