Apache won't start

Discussion in 'ISPConfig 3 Priority Support' started by jpcyrenne, Sep 12, 2014.

  1. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Good day,

    I have installed my first ISPConfig on Debian 7 (usually use CentOS).

    I followed the perfect Wheezy procedure:
    http://www.howtoforge.com/perfect-server-debian-wheezy-apache2-bind-dovecot-ispconfig-3-p5


    Issue 1 : I couldn't access /phpmyadmin before I installed ISPConfig, but I could access /squirelmail (Apache was good)

    Could it be a question of chgrp www-data rights on the phpmyadmin folder?



    Issue 2 : I can't access ISPConfig https://IP:8080


    # service apache2 restart
    Syntax error on line 30 of /etc/apache2/sites-enabled/000-apps.vhost:
    Invalid command 'SuexecUserGroup', perhaps misspelled or defined by a module not included in the server configuration
    Action 'configtest' failed.
    The Apache error log may have more information.
    failed!


    # vi /etc/apache2/sites-enabled/000-apps.vhost
    ######################################################
    # This virtual host contains the configuration
    # for the ISPConfig apps vhost
    ######################################################

    Listen 8081
    # NameVirtualHost *:8081

    <VirtualHost _default_:8081>
    ServerAdmin [email protected]


    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>

    <IfModule mod_php5.c>
    DocumentRoot /var/www/apps
    AddType application/x-httpd-php .php
    <Directory /var/www/apps>
    Options FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>
    </IfModule>

    <IfModule mod_fcgid.c>
    DocumentRoot /var/www/apps
    SuexecUserGroup ispapps ispapps
    <Directory /var/www/apps>
    Options +Indexes +FollowSymLinks +MultiViews +ExecCGI
    AllowOverride AuthConfig Indexes Limit Options FileInfo
    <FilesMatch "\.php$">
    SetHandler fcgid-script
    </FilesMatch>
    FCGIWrapper /var/www/php-fcgi-scripts/apps/.php-fcgi-starter .php
    Order allow,deny
    Allow from all
    </Directory>
    </IfModule>

    </VirtualHost>

    Happy to see that the default version of PHP is higher on Debian (5.4) than CentOS (5.3)

    Thanks,

    JP
     
  2. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    FYI

    [email protected]:/var/log/apache2# less error.log
    ...
    PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/ming.ini on line 1 in Unknown on line 0
    [Fri Sep 12 14:39:01 2014] [error] python_init: Python version mismatch, expected '2.7.2+', found '2.7.3'.
    [Fri Sep 12 14:39:01 2014] [error] python_init: Python executable found '/usr/bin/python'.
    [Fri Sep 12 14:39:01 2014] [error] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-linux2:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Fri Sep 12 14:39:01 2014] [notice] mod_python: Creating 8 session mutexes based on 10 max processes and 0 max threads.
    [Fri Sep 12 14:39:01 2014] [notice] mod_python: using mutex_directory /tmp
    [Fri Sep 12 14:39:01 2014] [notice] Apache/2.2.22 (Debian) DAV/2 mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.6 PHP/5.4.4-14+deb7u14 mod_python/3.3.1 Python/2.7.3 mod_ruby/1.2.6 Ruby/1.8.7(2012-02-08) configured -- resuming normal operations
    [Fri Sep 12 14:40:08 2014] [notice] Graceful restart requested, doing restart
    [Fri Sep 12 14:40:08 2014] [notice] Digest: generating secret for digest authentication ...
    [Fri Sep 12 14:40:08 2014] [notice] Digest: done
    [Fri Sep 12 14:40:08 2014] [notice] FastCGI: process manager initialized (pid 25539)
    PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/ming.ini on line 1 in Unknown on line 0
    [Fri Sep 12 14:40:08 2014] [error] python_init: Python version mismatch, expected '2.7.2+', found '2.7.3'.
    [Fri Sep 12 14:40:08 2014] [error] python_init: Python executable found '/usr/bin/python'.
    [Fri Sep 12 14:40:08 2014] [error] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-linux2:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Fri Sep 12 14:40:08 2014] [notice] mod_python: Creating 8 session mutexes based on 10 max processes and 0 max threads.
    [Fri Sep 12 14:40:08 2014] [notice] mod_python: using mutex_directory /tmp
    [Fri Sep 12 14:40:08 2014] [notice] Apache/2.2.22 (Debian) DAV/2 mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.6 PHP/5.4.4-14+deb7u14 mod_python/3.3.1 Python/2.7.3 mod_ruby/1.2.6 Ruby/1.8.7(2012-02-08) configured -- resuming normal operations
    [Fri Sep 12 14:41:09 2014] [error] [client 70.29.139.223] File does not exist: /var/www/favicon.ico
    [Fri Sep 12 14:41:52 2014] [error] [client 70.29.139.223] File does not exist: /var/www/phpmyadmin
    [Fri Sep 12 14:42:06 2014] [error] [client 70.29.139.223] File does not exist: /var/www/phpMyAdmin
    [Fri Sep 12 14:43:35 2014] [notice] Graceful restart requested, doing restart
    [Fri Sep 12 14:43:35 2014] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
    [Fri Sep 12 14:43:36 2014] [notice] Digest: generating secret for digest authentication ...
    [Fri Sep 12 14:43:36 2014] [notice] Digest: done
    [Fri Sep 12 14:43:36 2014] [notice] FastCGI: process manager initialized (pid 25590)
    PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/ming.ini on line 1 in Unknown on line 0
    [Fri Sep 12 14:43:36 2014] [error] python_init: Python version mismatch, expected '2.7.2+', found '2.7.3'.
    [Fri Sep 12 14:43:36 2014] [error] python_init: Python executable found '/usr/bin/python'.
    [Fri Sep 12 14:43:36 2014] [error] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-linux2:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Fri Sep 12 14:43:36 2014] [notice] mod_python: Creating 8 session mutexes based on 10 max processes and 0 max threads.
    [Fri Sep 12 14:43:36 2014] [notice] mod_python: using mutex_directory /tmp
    [Fri Sep 12 14:43:36 2014] [notice] Apache/2.2.22 (Debian) DAV/2 mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.6 PHP/5.4.4-14+deb7u14 mod_python/3.3.1 Python/2.7.3 mod_ruby/1.2.6 Ruby/1.8.7(2012-02-08) configured -- resuming normal operations


    Is there an issue with PHP and or Python?

    Thanks,

    JP
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    No.Please dont change any settings. Just follow the tutorial. I installed a server yesterday evening for a customer, 100% copy/paste of all commands and the server worked out the box, so it is guaramteed that there are no issues in the guide and that nox extra steps are required.

    Regarding to your issue,you missed toecute commands from the tutorial. See page:

    http://www.howtoforge.com/perfect-server-debian-wheezy-apache2-bind-dovecot-ispconfig-3-p4

    what you missed is the command:

    a2enmod suexec rewrite ssl actions include

    and then restart apache.
     
  4. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Thanks, it has fixed the apache issue. I can access the control panel and /squirrelmail (/webmail).

    I still could't access /phpmyadmin? I didn't see anything in the procedure to configure phpmyadmin (create .conf file, aliases, chage auth to 'http'... like CentOS - like I'm used to).

    I even removed and reinstalled phpmyadmin and didn't get the question:
    Web server to reconfigure automatically: <-- apache2
    Configure database for phpmyadmin with dbconfig-common? <-- No

    I did not see any phpmyadmin.conf file anywhere in /etc/apache2 ?


    FIX:
    -----
    I created a symlink to the phpmyadmin folder (like I saw for squirrelmail) and it works. I can log in with MySQL user.

    # /etc/apache2/conf.d# ln -s /etc/phpmyadmin/apache.conf phpmyadmin.conf
    # service apache2 restart

    Is this OK? is there anything I need to do to secure it?


    Thanks again Sir,

    JP
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The reason is that this is not nescessary on Debian and Ubuntu.

    Thats ok. Then only cause that this symlink was not created automatically is that apache was not selected as configuration target during phpmyadmin install. E.g. if you did not set the checkbox there (going to the menu point with the cursor keys is not enough as it just highlights the menu but does not enable it).
     

Share This Page