Apache wont display test page

Discussion in 'Server Operation' started by ITGuy, Feb 12, 2010.

  1. ITGuy

    ITGuy New Member

    I get the apache home screen, but my test pages will not display. Im running Fedora 10 in VM using Sun VB and I followed the "Perfect Server for Fedora 10" tutorial but due to so many complications w/ it. I've been trying for about a week now trying to get it to work. I did in w/ ISPConfig restored all the original files that I had edited as the tutorial says. I left the firewall disabled and SElinux disabled though. I just wanted a development environment anyway so this is fine, but when I cant get any of test pages to show up. I know it see's them b/c it displays a page, it's just blank. I even erased the file and tried to get to it and it says the url cant be found on the server. So I know it see's the file and is opening the file, but it wont display the php info file which I copied and pasted from the LAMP tutorial. Any clues?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    ISPConfig 2 or 3?
    How did you try to access the web sites? Through their hostnames/domains or through the IP address?
     
  3. ITGuy

    ITGuy New Member

    I swear your the only guy who replies on here.lol

    ISPConfig 2 but Im not running it anymore. I created another VM that I followed the LAMP how to w/ Fedora 12. Its running fine but it only displays the php info page. I put files in the same folder w/ the php info file, I tried HTML code, php code, but it will not display anything besides the php info page. It's like the only line of code it knows is phpinfo(), if I try anything else I get a blank page. If I put code in the file before the php info line, it will display the blank page. The only It opens up the file and displays a blank page. I've triid localhost and the ip, both give the results described above.
     
    Last edited: Feb 13, 2010
  4. falko

    falko Super Moderator ISPConfig Developer

    Any errors in Apache's error log?
     
  5. ITGuy

    ITGuy New Member

    Heres the log. Im not sure whats related and what isnt.

    [Sun Feb 14 14:18:04 2010] [notice] Digest: generating secret for digest authentication ...
    [Sun Feb 14 14:18:04 2010] [notice] Digest: done
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/php_mapscript.so' - /usr/lib64/php/modules/php_mapscript.so: undefined symbol: php_gd_gdImageCopy in Unknown on line 0
    [Sun Feb 14 14:18:04 2010] [error] python_init: Python version mismatch, expected '2.6', found '2.6.2'.
    [Sun Feb 14 14:18:04 2010] [error] python_init: Python executable found '/usr/bin/python'.
    [Sun Feb 14 14:18:04 2010] [error] python_init: Python path being used '/usr/lib64/python26.zip:/usr/lib64/python2.6/:/usr/lib64/python2.6/plat-linux2:/usr/lib64/python2.6/lib-tk:/usr/lib64/python2.6/lib-old:/usr/lib64/python2.6/lib-dynload'.
    [Sun Feb 14 14:18:04 2010] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
    [Sun Feb 14 14:18:04 2010] [notice] mod_python: using mutex_directory /tmp
    [Sun Feb 14 14:18:04 2010] [notice] Apache/2.2.14 (Unix) DAV/2 PHP/5.3.1 mod_python/3.3.1 Python/2.6.2 mod_ssl/2.2.14 OpenSSL/1.0.0-fips-beta3 mod_perl/2.0.4 Perl/v5.10.0 configured -- resuming normal operations
    [Sun Feb 14 20:32:24 2010] [notice] caught SIGTERM, shutting down
    [Sun Feb 14 20:33:07 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Sun Feb 14 20:33:07 2010] [notice] Digest: generating secret for digest authentication ...
    [Sun Feb 14 20:33:07 2010] [notice] Digest: done
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/php_mapscript.so' - /usr/lib64/php/modules/php_mapscript.so: undefined symbol: php_gd_gdImageCopy in Unknown on line 0
    [Sun Feb 14 20:33:08 2010] [error] python_init: Python version mismatch, expected '2.6', found '2.6.2'.
    [Sun Feb 14 20:33:08 2010] [error] python_init: Python executable found '/usr/bin/python'.
    [Sun Feb 14 20:33:08 2010] [error] python_init: Python path being used '/usr/lib64/python26.zip:/usr/lib64/python2.6/:/usr/lib64/python2.6/plat-linux2:/usr/lib64/python2.6/lib-tk:/usr/lib64/python2.6/lib-old:/usr/lib64/python2.6/lib-dynload'.
    [Sun Feb 14 20:33:08 2010] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
    [Sun Feb 14 20:33:08 2010] [notice] mod_python: using mutex_directory /tmp
    [Sun Feb 14 20:33:08 2010] [notice] Apache/2.2.14 (Unix) DAV/2 PHP/5.3.1 mod_python/3.3.1 Python/2.6.2 mod_ssl/2.2.14 OpenSSL/1.0.0-fips-beta3 mod_perl/2.0.4 Perl/v5.10.0 configured -- resuming normal operations
     
  6. ITGuy

    ITGuy New Member

    Could this be it

    [Sun Feb 14 14:18:04 2010] [notice] Digest: done
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/php_mapscript.so' - /usr/lib64/php/modules/php_mapscript.so: undefined symbol: php_gd_gdImageCopy in Unknown on line 0
     
  7. falko

    falko Super Moderator ISPConfig Developer

  8. ITGuy

    ITGuy New Member

    [Mon Feb 15 14:42:35 2010] [notice] caught SIGTERM, shutting down
    [Mon Feb 15 14:42:45 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Mon Feb 15 14:42:45 2010] [notice] Digest: generating secret for digest authentication ...
    [Mon Feb 15 14:42:45 2010] [notice] Digest: done
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/php_mapscript.so' - /usr/lib64/php/modules/php_mapscript.so: undefined symbol: php_gd_gdImageCopy in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/php_mapscript.so' - /usr/lib64/php/modules/php_mapscript.so: undefined symbol: php_gd_gdImageCopy in Unknown on line 0
    [Mon Feb 15 14:42:46 2010] [error] python_init: Python version mismatch, expected '2.6', found '2.6.2'.
    [Mon Feb 15 14:42:46 2010] [error] python_init: Python executable found '/usr/bin/python'.
    [Mon Feb 15 14:42:46 2010] [error] python_init: Python path being used '/usr/lib64/python26.zip:/usr/lib64/python2.6/:/usr/lib64/python2.6/plat-linux2:/usr/lib64/python2.6/lib-tk:/usr/lib64/python2.6/lib-old:/usr/lib64/python2.6/lib-dynload'.
    [Mon Feb 15 14:42:46 2010] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
    [Mon Feb 15 14:42:46 2010] [notice] mod_python: using mutex_directory /tmp
    [Mon Feb 15 14:42:46 2010] [notice] Apache/2.2.14 (Unix) DAV/2 PHP/5.3.1 mod_python/3.3.1 Python/2.6.2 mod_ssl/2.2.14 OpenSSL/1.0.0-fips-beta3 mod_perl/2.0.4 Perl/v5.10.0 configured -- resuming normal operations
    [Mon Feb 15 14:49:02 2010] [error] [client 192.168.1.118] PHP Parse error: syntax error, unexpected T_STRING, expecting ',' or ';' in /var/www/html/test2.php on line 9
    [Mon Feb 15 14:49:02 2010] [error] [client 192.168.1.118] File does not exist: /var/www/html/favicon.ico
    [Mon Feb 15 14:49:05 2010] [error] [client 192.168.1.118] File does not exist: /var/www/html/favicon.ico
    [Mon Feb 15 14:57:40 2010] [error] [client 192.168.1.118] PHP Parse error: syntax error, unexpected T_STRING, expecting ',' or ';' in /var/www/html/test2.php on line 9
     
  9. ITGuy

    ITGuy New Member

    Followed those instructions, and I still got the error. Here are the ones from today, listed above. The last error doesnt make sense because that line of code is correct and their is the ";" at the end.
     
    Last edited: Feb 15, 2010

Share This Page