Apache Warning /var/www

Discussion in 'Server Operation' started by Acker, Jan 30, 2009.

  1. Acker

    Acker New Member

    Hi there,

    i recently installed ispconfig 2.2.29 on an ubuntu 8.04 server with the help of the tutorials here.

    Everything seems to work so far, but i got this warning message in the apache log nearly every second:

    [error] [client 127.0.0.1] Directory index forbidden by Options directive: /var/www/

    is there a way to solve this problem, so that my logfile will not be full in some minutes.

    Best regards,
    Acker
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/apache2/sites-available/default?
     
  3. Acker

    Acker New Member

    Hi and thx for your help.

    Here is the content of the file 000-default

    Code:
    NameVirtualHost *
    <VirtualHost *>
            ServerAdmin [email protected]
    
            DocumentRoot /var/www/
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/>
                    Options -Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
                    # This directive allows us to have apache2's default start page
                    # in /apache2-default/, but still have / go to the right place
                    #RedirectMatch ^/$ /apache2-default/
            </Directory>
    
            ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
            <Directory "/usr/lib/cgi-bin">
                    AllowOverride None
                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all
            </Directory>
    
            ErrorLog /var/log/apache2/error.log
    
            # Possible values include: debug, info, notice, warn, error, crit,
            # alert, emerg.
            LogLevel warn
    
            CustomLog /var/log/apache2/access.log combined
            ServerSignature On
    
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
        </Directory>
    </VirtualHost>
    
    
    Best regards,
    Acker
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Change
    Code:
            <Directory /var/www/>
                    Options [COLOR="Red"]-[/COLOR]Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
                    # This directive allows us to have apache2's default start page
                    # in /apache2-default/, but still have / go to the right place
                    #RedirectMatch ^/$ /apache2-default/
            </Directory>
    to
    Code:
            <Directory /var/www/>
                    Options [COLOR="Red"]+[/COLOR]Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
                    # This directive allows us to have apache2's default start page
                    # in /apache2-default/, but still have / go to the right place
                    #RedirectMatch ^/$ /apache2-default/
            </Directory>
    and restart Apache.
     
  5. Acker

    Acker New Member

    Hi!

    Thx for your hint. I guess +Indexes should just be Indexes without a character before, right?

    The log is clear now, no more errors. Thx again!

    Best regards,
    Acker
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Doesn't matter in this case. :)
     

Share This Page