Apache stops working after about 20 minutes

Discussion in 'Installation/Configuration' started by pjack, Dec 26, 2010.

  1. pjack

    pjack New Member

    Apache seems to just stop working after about 20 minutes and I have to restart the service. I saw this person with a similar issue

    http://www.howtoforge.com/forums/sho...ghlight=apache

    I don't know if this is my problem but I'm not sure how to go about fixing it or why it's doing this.

    Any help please?
     
  2. pjack

    pjack New Member

    Does anyone know anything about this?
     
  3. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Are there any errors in Apache's error log?
     
  4. pjack

    pjack New Member

    line 148.
    piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
    Can't locate Date/Format.pm in @INC (@INC contains: /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8) at /usr/local/ispconfig/server/scripts/vlogger line 148.
    BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 148.
    piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
    Can't locate Date/Format.pm in @INC (@INC contains: /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8) at /usr/local/ispconfig/server/scripts/vlogger line 148.
    BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 148.

    I didn't install Vlogger, would that cause the issue? It shouldn't have anything to do with apache though right?
     
  5. pjack

    pjack New Member

    Ok, I installed Vlogger to make sure there was nothing up with that.
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    The Date::Format Perl module isn't installed. Which distribution do you use?
     
  7. alleks

    alleks Member

    go install Date::Format into pearl and see if keeps failing

    How to install

    Code:
    #perl -MCPAN -e shell
    #perl install Date::Format
    
     

Share This Page