apache stopped ... not restarted...

Discussion in 'Installation/Configuration' started by gilas, May 25, 2009.

  1. gilas

    gilas New Member

    3 days ago i installed correctly without errors ISPConfig version 3.0.1.1
    today I attemped an update to 3.0.1.2. version, failed. This is the last log lines:

    Stopping Courier POP3-SSL server: pop3d-ssl.
    Starting Courier POP3-SSL server: pop3d-ssl.
    [Mon May 25 08:16:27 2009] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
    [Mon May 25 08:16:27 2009] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
    Restarting web server: apache2 failed!
    Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -A -O clf:/var/log/pure-ftpd/transfer.log -E -b -u 1000 -B
    Update finished.
    web11:~/ispconfig3_install/install# /etc/inid
    web11:~/ispconfig3_install/install# /etc/init.d/apache2 restart
    Restarting web server: apache2[Mon May 25 08:17:06 2009] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
    [Mon May 25 08:17:06 2009] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
    failed!
    web11:~/ispconfig3_install/install#

    apache doesn' restart anymore.

    Note: I'm working under lenny v. 5.0.1. To force the previous ISPConfig install (v. 3.0.1.1) I modified a line within the installer; this because the installer doesn't recognize my version and stops (checks only looking for "5.0" string and not for "5.0.1" with a trim funcion in PHP).

    Thank you very much
     
  2. till

    till Super Moderator

    Please take a loom into the apache error log to find the reason why it does not start.
     
  3. gilas

    gilas New Member

    apache2 error log....

    Hi Till
    many thanx.... this is the extract of error.log (apache):

    [Mon May 25 07:07:04 2009] [warn] Init: SSL server IP/port conflict: prova002.xxxxx.it:443 (/etc/apache2/sites-enabled/prova002.xxxxx.it.vhost:74) vs. prova003.cc.xxxxx.it:443 (/etc/apache2/sites-enabled/prova003.cc.xxxxx.it.vhost:66)
    [Mon May 25 07:07:04 2009] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
    [Mon May 25 07:07:04 2009] [notice] Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny3 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
    [Mon May 25 07:07:04 2009] [warn] long lost child came home! (pid 1024)
    [Mon May 25 07:08:01 2009] [notice] Graceful restart requested, doing restart
    [Mon May 25 07:08:04 2009] [warn] _default_ VirtualHost overlap on port 443, the first has precedence


    NOTE: I wish to use ISPConfig 3.x a self-signed certificate for each site.
    Trying ISPConfig I have only created two sites and for each site a cert.
     
  4. till

    till Super Moderator

    You have to select a different IP address for every site were you enable SSL. You can not use * for SSL sites.
     
  5. gilas

    gilas New Member

    do you mean ...

    the following code (from: /etc/apache2/sites-enabled/hostname.domain.it.vhost)

    ###########################################################
    # SSL Vhost
    ###########################################################

    <VirtualHost *:443>
    DocumentRoot /var/www/clients/client1/web1/web


    now the problems is that I can access to ISPConfig to modify the records, so I can do it manually. Maybe I must to youse an IP address for each site activated (i.e. substitute in the line above the asterisk with the IP)?

    I have not IP free; I need to switch to the previous (not SSL) configuration; I suppose to do this I must to clear all the SSL Vhost section from apache configuration file for each host or I make a mistake?!?

    Thank you very much....
     
  6. till

    till Super Moderator

    You have to select the IP address in ISPConfig and not * in the website settings as I told you below. You dont have to access or midify any files!
     
  7. gilas

    gilas New Member

    reinstalled

    Hi Till
    the problem is that if I do not modify (manually) I can't restart apache; if I can restart apache I can't use ISPConfig admin panel.

    I have uninstalled/reinstalled ISPConfig3 (db was lost... no problem...).

    Then I tried (if happens to other people) this:

    edit each file in /etc/apache2/site-enabled/

    removing the SSL section.

    Before: copy into another location the files to modify; not in the same folder otherwise apache includes them!!!

    Restarting apache2 all is OK.

    Now there is another little problem: howto SSL the panel? I connect to:
    www.mysite.it:8080

    but this is not a SECURE CONNECTION....

    Thank you very much for all.
     

Share This Page