Apache start problem

Discussion in 'ISPConfig 3 Priority Support' started by pawan, Mar 8, 2016.

  1. pawan

    pawan Member HowtoForge Supporter

    I have installed fresh ubuntu server12.04 with latest ispconfig. Copied all the files from old hdd to new server installation like
    var/www
    var/lib/mysql
    etc/apache2/sties-available
    etc/apache2/sites-enabled
    etc/group
    etc/bind
    but now when I am starting apache I am getting the error like
    Code:
    [email protected]:~$ sudo service apache2 restart
    * Restarting web server apache2                                                [Tue Mar 08 18:49:14 2016] [warn] NameVirtualHost 192.168.0.10:443 has no VirtualHosts
    [Tue Mar 08 18:49:14 2016] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Tue Mar 08 18:49:14 2016] [warn] NameVirtualHost 192.168.0.10:443 has no VirtualHosts
    [Tue Mar 08 18:49:14 2016] [warn] NameVirtualHost *:443 has no VirtualHosts
    Action 'start' failed.
    The Apache error log may have more information.
                                                                             [fail]
     
  2. pawan

    pawan Member HowtoForge Supporter

    Resolved log file was missing. Added from old hdd. Now apache starts
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    I hope you did not copy the whole /etc/passd and /etc/group files? Only the web[ID] users and clien[ID] groups have to be copied.
     
  4. pawan

    pawan Member HowtoForge Supporter

    Hi Till I think you are right I have copied the whole file but I have kept a backup of the original file.
    As per your suggestion I should copy only the relevant part for web[ID] AND Client[id] and modify the existing file right?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, that's right. Copy just the lines for the web* users over from /etc/passwd and /etc/shadow and only the client* groups from /etc/group and /etc/gshadow. You can do a final check on the resulting files with the commands pwck and grpck.
     
  6. pawan

    pawan Member HowtoForge Supporter

    Hi Till I had resolved some of the errors. But I am facing some new problems for example I had APC cache installed in my earlier server.
    Now following the perfect server guide I have installed xcache.
    Now for some vhosts I am getting the error in the vhost error log and the site doesn't open.
    Code:
    [Tue Mar 08 22:31:34 2016] [warn] [client 117.247.67.131] mod_fcgid: stderr: PHP Fatal error:  Call to undefined function apc_fetch() in /var/www/clients/client2/web13/web/libraries/joomla/cache/storage/apc.php on line 36
     
  7. pawan

    pawan Member HowtoForge Supporter

    Ok I have installed apc using apt-get and the sites are opening. Rest edits I will do carefully and report.
     

Share This Page