apache special characters

Discussion in 'Server Operation' started by rayit, Sep 28, 2008.

  1. rayit

    rayit New Member

    Hello All

    how should I solve the problem with international characters on the websites.
    I recently moved site to new server and this problem started.

    I reinstall locales and changed the apache2.conf AddDefault... with utf-8.

    I had the problem few years ago but can not remember the sollution.
    I only see blocks and not the special characters..

    Many thanks!

  2. falko

    falko Super Moderator ISPConfig Developer

    Please put
    AddDefaultCharset ISO-8859-1
    in your Apache configuration and restart Apache.
  3. rayit

    rayit New Member

    not working

    Hello Falko
    it's not working


    I uncommented the line and changed AddDefaultCharset utf-8 to AddDefaultCharset ISO-8859-1

    I also changed

    but that does not help.
    I had it before on a server but can't not remember the sollution.. duh...
    It's a xen client..

    some more tips to try??
  4. marpada

    marpada New Member

    Check the locale of the server (I think it's /etc/sysconfig/i18n)
    Does the page use some Mysql database. If so, check also the collation of the db.
    Iolite vape review
    Sex Advice Forums
    Last edited: May 13, 2011
  5. rayit

    rayit New Member

    wow SOLVED

    I added Charset=UTF-8 after the IndexOptions and restarted apache and it's solved. :D

    IndexOptions FancyIndexing VersionSort HTMLTable NameWidth=* Charset=UTF-8

    Hope nexttime I will remember...

    gr and thanks

Share This Page