Apache root

Discussion in 'Installation/Configuration' started by aaronkm, Sep 4, 2008.

  1. aaronkm

    aaronkm New Member

    Hello HowtoForge,

    I hope this post finds you well.

    I've added my first website to my ISPConfig install. (2.2.4)
    The DNS resolves as it should but when I browse to the site, the default apache folder is served from /var/www/html instead of what is in the Vhost conf file. (/var/www/web7/web)

    Below is my Vhost's conf file, not sure if it helps diagnose or not.

    Thanks for any insight on what I've done wrong.



    Code:
    NameVirtualHost 96.225.168.6:80
    <VirtualHost 96.225.168.6:80>
     ServerName localhost
     ServerAdmin root@localhost
     DocumentRoot /var/www/sharedip
     <IfModule mod_rewrite.c>
       RewriteEngine on
       RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
       RewriteRule .* - [F]
     </IfModule>
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: www.advantagecamps.org:80
    ######################################
    #
    #
    <VirtualHost 96.225.168.6:80>
    ServerName www.advantagecamps.org:80
    ServerAdmin [email protected]
    DocumentRoot /var/www/web7/web
    ServerAlias advantagecamps.org
    DirectoryIndex index.html index.htm index.php aaron.test
    ErrorLog /var/www/web7/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
       SetOutputFilter PHP
       SetInputFilter PHP
    </Files>
    <Files *.php3>
       SetOutputFilter PHP
       SetInputFilter PHP
    </Files>
    <Files *.php4>
       SetOutputFilter PHP
       SetInputFilter PHP
    </Files>
    <Files *.php5>
       SetOutputFilter PHP
       SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    Alias /error/ "/var/www/web7/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web7/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web7/user/$1/web/$3
    <IfModule mod_rewrite.c>
     RewriteEngine on
     RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
     RewriteRule .* - [F]
    </IfModule>
    </VirtualHost>
    
     
  2. jon

    jon Member HowtoForge Supporter

    Have you disabled the default site config that comes with your distro? Perhaps it's being hit first, and directing you there.

    In your console try ...

    cd /etc/apache2 (assuming this is your apache2 config directory)
    grep -ir "var/www/html" *

    And see if it returns the offending config file.

    If you were running Debian, you could run a2dissite and disable default
     
  3. aaronkm

    aaronkm New Member

    Bingo!

    Thanks Jon.

    I thought that was it.

    I changed the httpd.conf file

    from <Directory "/var/www/html">
    to <Directory "/var/www">

    And it now shows the contents of /var/www when I point my browser to www.advantagecamps.org

    If I change it back to /var/www/html it takes me back to the apache root /var/www/html

    Thought that was the answer but no. :(
     
    Last edited: Sep 4, 2008
  4. aaronkm

    aaronkm New Member

    I made the mistake of using a live IP instead of the local non-routable IP.

    Making that change squared things away.

    Thanks again for the assist.
    :)
     

Share This Page