Apache Problems - I think

Discussion in 'Server Operation' started by roonui, Aug 11, 2008.

  1. roonui

    roonui New Member

    Hi, I am having issues. I have an ubuntu 7.10 server which has subversion and bugzilla on it. Today I tried an svn update, but i get:

    svn: PROPFIND request failed on 'svn/.../trunk'
    svn: PROPFIND of '/svn/.../trunk': Could not read status line: AN existing connection was forcibly closed by the remote host. (http://servername)

    Also, i cannot open the default site in my browser, nor the bugzilla site in my browser.

    Also, when i try to restart apache i get this:

    sudo apache2 -k restart
    httpd not running, trying to start
    (98)Address already in use: make_sock: could not bind to address
    no listening sockets available, shutting down
    Unable to open logs

    Now, I have no clue what I am doing, but i believe it may be apache? . Any help much appreciated.

  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    netstat -tap
    ? Any errors in Apache's error log?
  3. roonui

    roonui New Member

    [email protected]:~$ sudo netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:svn *:* LISTEN 4284/svnserve
    tcp 0 0 localhost:mysql *:* LISTEN 4168/mysqld
    tcp 0 0 *:netbios-ssn *:* LISTEN 4279/smbd
    tcp 0 0 localhost:postgresql *:* LISTEN 4242/postgres
    tcp 0 0 *:microsoft-ds *:* LISTEN 4279/smbd
    tcp 1 0 192.168.0.:microsoft-ds CLOSE_WAIT -
    tcp 0 0 192.168.0.:microsoft-ds ESTABLISHED5997/smbd
    tcp6 0 0 *:ssh *:* LISTEN 4074/sshd
    tcp6 0 0 ::ffff: ::ffff:192.168.0.:49629 ESTABLISHED6002/sshd: richard

    Where can i find apaches error log? Thanks, any help much appreciated
    Last edited: Aug 13, 2008
  4. falko

    falko Super Moderator ISPConfig Developer

    The logs are in the /var/log/apache2 directory.
  5. roonui

    roonui New Member

    There are lots of zipped up files in there, but nothing recent that indicates the current problem. The most common ones in there are these:

    This one was in every log:

    apache2: Could not reliably determine the server's fully qualified domain name, using for ServerName

    [notice] (10)No child processes: cannot send signal 10 to pid 4294 (non-child or already dead)
    [error] [client] A failure occurred while driving the update report editor [500, #190004]

    Other errors i get:

    On apache2 -k stop:

    httpd (no pid file) not running

    On apache2 -k restart:

    httpd not running, trying to start
    (98)Address already in use: make_sock: could not bind to address
    no listening sockets available, shutting down
    Unable to open logs

    On apache2 -k start:

    (98)Address already in use: make_sock: could not bind to address
    no listening sockets available, shutting down
    Unable to open logs

    It says no PID file in that first error, where should that be located?
  6. ralic

    ralic New Member

    Instead of invoking the apache binary directly, have you tried using the default init script through sudo?
    sudo /etc/init.d/apache2 start
    sudo /etc/init.d/apache2 stop
    sudo /etc/init.d/apache2 restart
    sudo /etc/init.d/apache2 reload
  7. roonui

    roonui New Member

    Hi, thanks, yes i have but with the same error messages as above.
  8. falko

    falko Super Moderator ISPConfig Developer

    Have you tried to reboot the system?
  9. roonui

    roonui New Member

    yes i have tried that
  10. ralic

    ralic New Member

    The pid file can be found from the PidFile configuration setting in the apache2 configuration file (usually /etc/apache2/apache2.conf in Ubuntu). It's value is usually:
    PidFile /var/run/apache2.pid
    Seems that something else may already be using the port that apache wants to use. To see what's using that port number type and post the output of:
    sudo lsof -i :80
  11. roonui

    roonui New Member

    thanks guys, but i had to rebuild the server. i did check the value of the pid file in the config file before i rebuilt and it was set as above, and could see nothing else running on port 80.
  12. roonui

    roonui New Member

    ok another problem... following the install guide for subversion under the howto, but when i go to ./configure neon it tells me: error no xml parser was found: expat or libxml 2.x required.

    now, i apt-get install libxml2 and it tells me libxml is already the newest version. why can neon not see it?
  13. roonui

    roonui New Member

    ok forget that, got it. just wasnt configuring with the right location
  14. roonui

    roonui New Member

    ok here is a worse question, how do i find where apache is installed?

    ./configure --prefix=/usr/local/subversion --with-apxs={Location where you installed apache}/bin/apxs --with-apr=/usr/local/apr/ --with-apr-util=/usr/local/apr-util/ --with-neon=/usr/local/neon/ --with-ssl

    i installed apache straight from the ubuntu cd... i thought it would be /etc/apache2 but there is no bin/apxs folder in there
  15. roonui

    roonui New Member

    also found the answer to this elsewhere...so my svn server is now (sort of) running.
    I am up to here:

    Then make an initial import of the temporary created directory.

    /usr/local/subversion/bin/svn import /tmp/subversion-layout/

    this would not work, so i moved into the bin directory and executed:

    ./svn import /tmp/subversion-layout/ -m ""

    but i get:

    svn: Server sent unexpected return value (403 Forbidden) in response to OPTIONS request for ''

    i have gotten rid of authentication to try to remedy the problem, ie: took this out;

    AuthType Basic

    AuthName "{Name of the authentication popup tab}"

    AuthUserFile {Location of the password file}

    Require valid-user

    but just cant get it to work.

    i have tried restarting apache, and rebooting machine. could it be that my apache2 installation is not at /usr/local? mine is located in /etc/apache2, so i did:

    groupadd apache

    useradd -g apache -d /usr/local/apache2 <--this wouldnt work for me either... so i did useradd -g apache apache, then usermod -d /etc/apache2 apache

    After installing apache we need to set ownership of all the files in /usr/local/apache2 to user apache.

    chown -Rv apache.apache /usr/local/apache2 <--then here chown -Rv apache.apache /etc/apache2

    have been stuck on this for a while now. any ideas???
    Last edited: Aug 21, 2008
  16. falko

    falko Super Moderator ISPConfig Developer

    What do you get when you run
  17. ralic

    ralic New Member

    Is there any particular reason that you are installing subversion from the source? Perhaps coming from a linux distro that lacks a repository environment?

    I'd suggest that you take a look here Ubuntu Server Guide. There's a link to subversion under the heading Version Control System. There are plenty of other topics covered that you're likely to run into too. When you install software from the repository, dependencies are met and you don't have to hack things into shape. Subversion would install and be compatible with apache out of the box. You'd only need to fine tune it.

    If you require some esoteric option, by all means go for a source compile and install, but it wouldn't be my first choice with ubuntu. I'd do a repo install and only if that fell short would I revert to source. I came to ubuntu from slackware, so I know all about dependency hell.
  18. roonui

    roonui New Member

    Thanks ralic, following that guide got everything up and running easily. Cheers!

Share This Page