apache+php+fastcgi, http 500 error occurred, fastcgi die

Discussion in 'HOWTO-Related Questions' started by kimixie, Dec 5, 2014.

  1. kimixie

    kimixie New Member

    --------------------------------------------------------------------------------

    HI guys, can someone help me with this problem?
    I build the environment with apache2.2.29 + php-5.3.29 + mod_fastcgi-2.4.6 in a arm based system, and I met a problem below,

    [Thu Jan 01 00:04:36 1970] [notice] Digest: generating secret for digest authentication ...
    [Thu Jan 01 00:04:36 1970] [notice] Digest: done
    [Thu Jan 01 00:04:36 1970] [notice] Apache/2.2.29 (Unix) DAV/2 mod_fastcgi/2.4.6 configured -- resuming normal operations
    [Thu Jan 01 00:04:36 1970] [notice] FastCGI: process manager initialized (pid 2135)
    [Thu Jan 01 00:04:36 1970] [warn] FastCGI: server "/fss/gw/bin/php-cgi" started (pid 2141)
    /fss/gw/bin/php-cgi: can't load library 'libz.so.1'
    [Thu Jan 01 00:04:36 1970] [warn] FastCGI: server "/fss/gw/bin/php-cgi" (pid 2141) terminated by calling exit with status '16'
    [Thu Jan 01 00:04:37 1970] [warn] FastCGI: server "/fss/gw/bin/php-cgi" started (pid 2146)
    /fss/gw/bin/php-cgi: can't load library 'libz.so.1'
    [Thu Jan 01 00:04:37 1970] [warn] FastCGI: server "/fss/gw/bin/php-cgi" (pid 2146) terminated by calling exit with status '16'
    [Thu Jan 01 00:04:38 1970] [warn] FastCGI: server "/fss/gw/bin/php-cgi" started (pid 2151)
    /fss/gw/bin/php-cgi: can't load library 'libz.so.1'
    [Thu Jan 01 00:04:38 1970] [warn] FastCGI: server "/fss/gw/bin/php-cgi" (pid 2151) terminated by calling exit with status '16'
    [Thu Jan 01 00:04:39 1970] [warn] FastCGI: server "/fss/gw/bin/php-cgi" started (pid 2156)
    /fss/gw/bin/php-cgi: can't load library 'libz.so.1'
    [Thu Jan 01 00:04:40 1970] [warn] FastCGI: server "/fss/gw/bin/php-cgi" (pid 2156) terminated by calling exit with status '16'
    [Thu Jan 01 00:04:40 1970] [warn] FastCGI: server "/fss/gw/bin/php-cgi" has failed to remain running for 30 seconds given 3 attempts, its restart interval has been backed off to 600 seconds
    [Thu Jan 01 00:04:40 1970] [warn] FastCGI: server "/fss/gw/bin/php-cgi" has failed to remain running for 30 seconds given 3 attempts, its restart interval has been backed off to 600 seconds
    [Thu Jan 01 00:04:40 1970] [warn] FastCGI: server "/fss/gw/bin/php-cgi" has failed to remain running for 30 seconds given 3 attempts, its restart interval has been backed off to 600 seconds
    [Thu Jan 01 00:04:40 1970] [warn] FastCGI: server "/fss/gw/bin/php-cgi" has failed to remain running for 30 seconds given 3 attempts, its restart interval has been backed off to 600 seconds
    [Thu Jan 01 00:04:40 1970] [warn] FastCGI: server "/fss/gw/bin/php-cgi" has failed to remain running for 30 seconds given 3 attempts, its restart interval has been backed off to 600 seconds
    [Thu Jan 01 00:04:41 1970] [warn] FastCGI: server "/fss/gw/bin/php-cgi" has failed to remain running for 30 seconds given 3 attempts, its restart interval has been backed off to 600 seconds
    [Thu Jan 01 00:04:41 1970] [warn] FastCGI: server "/fss/gw/bin/php-cgi" has failed to remain running for 30 seconds given 3 attempts, its restart interval has been backed off to 600 seconds
    [Thu Jan 01 00:04:41 1970] [warn] FastCGI: server "/fss/gw/bin/php-cgi" has failed to remain running for 30 seconds given 3 attempts, its restart interval has been backed off to 600 seconds
    [Thu Jan 01 00:04:41 1970] [warn] FastCGI: server "/fss/gw/bin/php-cgi" has failed to remain running for 30 seconds given 3 attempts, its restart interval has been backed off to 600 seconds
    [Thu Jan 01 00:04:41 1970] [warn] FastCGI: server "/fss/gw/bin/php-cgi" has failed to remain running for 30 seconds given 3 attempts, its restart interval has been backed off to 600 seconds
    [Thu Jan 01 00:05:17 1970] [error] [client 192.168.1.24] FastCGI: comm with server "/fss/gw/bin/php-cgi" aborted: idle timeout (30 sec)
    [Thu Jan 01 00:05:17 1970] [error] [client 192.168.1.24] FastCGI: incomplete headers (0 bytes) received from server "/fss/gw/bin/php-cgi"

    while actually libz.so.1 exist under /fss/gw/lib/ which is set in LD_LIBRARY_PATH env variable.
    but php-cgi can Executed individually successfully like this
    # /fss/gw/bin/php-cgi -v
    PHP 5.3.29 (cgi-fcgi) (built: Dec 5 2014 00:07:08)
    Copyright (c) 1997-2014 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2014 Zend Technologies
    # /fss/gw/bin/php -v
    PHP 5.3.29 (cli) (built: Dec 5 2014 00:07:10)
    Copyright (c) 1997-2014 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2014 Zend Technologies


    # /fss/gw/bin/php-cgi -f /var/test.php
    hello world!
    #
    #
    #
    # cat /var/test.php
    <?php
    echo "hello world!";
    echo "\n";
    ?>
    #

    and I'm a little confused, why can execute individully?
    plz someone help me with this, thx very much!
     
    Last edited: Dec 5, 2014
  2. conductive

    conductive Member

    If the module is not on your arm you probably have to recompile or use a different kernel.
     

Share This Page