Apache permissions / Wordpress Problems.

Discussion in 'Installation/Configuration' started by joshy92, Sep 25, 2013.

  1. joshy92

    joshy92 New Member

    This problem has been causing a headache for a few days. I've installed IspConfig3 onto an Unbuntu server, i've enabled temp domains similar to cPanel. (http://server.com/~site.com).

    Everything is working fine, however when I install Wordpress onto a site, it cannot write to the directory. Obviously this is to do with apache permissions. I've tried adding the client to the apache group and still no luck!

    Fast-CGI is enabled and so is SuEXEC. I don't want to manually change the permissions of 777 every time I create a site, this would also make the server very insecure.

    Any help would be gratefully appreciated.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This cpanel setup can not work on ispconfig servers as it will cause php scripts to run under a wrong user. In ISPConfig you configure the temporary access domain under System > server config > web. The option is named Website auto alias. No need for editing any config files, if you changed any apache config files, undo that first before you setup your temporry access domain in ispconfig.
    Last edited: Sep 25, 2013
  3. joshy92

    joshy92 New Member

    So the problem is because of this;
    I added this to the ispconfig.conf

    If that's the case, is it possible to get the temp domains working in that format on ISPconfig?

    After changing all the changed apache setting if i do this in the Server config of ISPconfig,
    if i changed web auto alias to: "/~[website_domain]" this should solve the problem?
    Last edited: Sep 25, 2013
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The above can not work as mod_userdir will run all php files as apache user and not website user, so suexec is disabled then and you wont have access to the files.

    No, as mod_suerdir is not able to switch the user correctly. For that reason, ispconfig uses a differebt method which will give you the correct results.

    No, thats not a valisd apache domain alias.

    You will use something like this:


    where yourdomain.tld is your company domain or the hostname of the server. Then you can access the site with the url:

  5. joshy92

    joshy92 New Member

    Thanks for the help, Just to clarify this for me (I'm very new to ISPConfig).

    I access my ISPconfig panel through a url like this : sever.domain.com
    with my previous set up temp domains would be seen as this: server.domain.com/~example.com

    With this website auto alias if now imput [website_domain].server.domain.com would this work? as example.com.server.domain.com?

    or does it need to create a new subdomain so [website_domain].domain.com?

    I hope that made sense.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. Just ensure that you add a wildcard dns entry for *.server.domain.com

  7. joshy92

    joshy92 New Member

    Is there a guide to do this? Thanks. Also when creating a site, do you need to create a DNS?
    Last edited: Sep 25, 2013

Share This Page