apache permission issue

Discussion in 'ISPConfig 3 Priority Support' started by budgierless, Mar 19, 2015.

  1. budgierless

    budgierless Member

    Hi,

    Everything was fine, but ubuntu 12.04 had an update for Apache, and now all new processes are showing in file manager as "www-data:www-data", how can i make Apache use "webX:clientX" like it did before? is their a way to make ispconfig3 tell Apache what to do?

    thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely the update disabled suexec. Try:

    a2enmod suexec

    And restart apache.
     
  3. budgierless

    budgierless Member

    its said Module suexec already enabled
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Hmm, ok. Please post the content of /etc/os-release file. Then check if there are any errors in the suexec log file and try to restart apache on the shell.
     
  5. budgierless

    budgierless Member

    below are the details, but i can see anything wrong, is the log output as exacted?

    etc/os-release:
    NAME="Ubuntu"
    VERSION="12.04.5 LTS, Precise Pangolin"
    ID=ubuntu
    ID_LIKE=debian
    PRETTY_NAME="Ubuntu precise (12.04.5 LTS)"
    VERSION_ID="12.04"

    suexec log sample:
    [2015-03-20 10:57:55]: uid: (5006/web4) gid: (5005/client0) cmd: .php-fcgi-starter
    [2015-03-20 11:11:16]: uid: (5012/web11) gid: (5005/client0) cmd: .php-fcgi-starter_web34
    [2015-03-20 11:11:20]: uid: (5012/web11) gid: (5005/client0) cmd: .php-fcgi-starter_web34
    [2015-03-20 11:11:45]: uid: (5006/web4) gid: (5005/client0) cmd: .php-fcgi-starter
    [2015-03-20 11:12:05]: uid: (5019/web18) gid: (5005/client0) cmd: .php-fcgi-starter
    [2015-03-20 11:21:02]: uid: (5019/web18) gid: (5005/client0) cmd: .php-fcgi-starter
    [2015-03-20 11:31:58]: uid: (5019/web18) gid: (5005/client0) cmd: .php-fcgi-starter
    [2015-03-20 11:40:29]: uid: (5017/web16) gid: (5005/client0) cmd: .php-fcgi-starter
    [2015-03-20 11:41:55]: uid: (5012/web11) gid: (5005/client0) cmd: .php-fcgi-starter_web34
    [2015-03-20 11:45:02]: uid: (5012/web11) gid: (5005/client0) cmd: .php-fcgi-starter_web34
    [2015-03-20 11:49:20]: uid: (5006/web4) gid: (5005/client0) cmd: .php-fcgi-starter
    [2015-03-20 11:55:24]: uid: (5019/web18) gid: (5005/client0) cmd: .php-fcgi-starter
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats both ok. May you please add a phpinfo() file into one of the affected websites and check which php handler is actually handling the php requests in the site and compare that with the php mode setting for that website in ispconfig.
     
  7. budgierless

    budgierless Member

    Php seems to match fine CP settings, website in the processes run by web11, 12, 13 etc. , but the /usr/sbin/apache process are run by www-data ?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats ok, apache runs always as www-data. Only php is run under the website user.
     
    budgierless likes this.

Share This Page