Apache page instead of ISPC3 on port 8080

Discussion in 'Installation/Configuration' started by Mickael, Oct 13, 2020.

  1. Mickael

    Mickael New Member

    Hello,
    First of all I want to apologize for my English, I am French...
    I followed this tutorial to the letter: perfect-server-debian-10-buster-apache-bind-dovecot-ispconfig-3-1

    I encountered some small problems during the execution of the Tuto, especially on the implementation of PHP. It was not activated so I had to follow another Tuto to activate PHP in apache ...

    The rest of the tutorial went very well and I would like to thank its editor who did a great job.
    The problem I have is that when I go to https:// myip:8080 I land on the apache page.
    I found a lot of people in the same situation as me, but the help they received did not solve my problem. Can you help me?

    Thank you for your help,
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The tutorial is fine and PHP is activated when using it, so you must have left something out. The first step is, undo what you did by using that other tutorial as it might cause ISPConfig to fail. Then go back to the ISPConfig perfect server guide and follow each step again to find out what you left out:

    https://www.howtoforge.com/perfect-server-debian-10-buster-apache-bind-dovecot-ispconfig-3-1/

    Btw, we test the tutorial frequently by copy&pasting all commands, the result is always a fully working setup, so there is nothing missing in the tutorial. And take care that you originally started with a completely empty system, if there was another control panel or LAM server installed before, format the server and start with an empty system again.
     
    ahrasis likes this.
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    ahrasis likes this.
  4. ahrasis

    ahrasis Well-Known Member

    Although troubleshooting is a good way to learn, the easiest fastest way that I see for you is to start a fresh based on the same tutorial since I assume it is your newly built server.
     
  5. Mickael

    Mickael New Member

    Hello everyone and thank you for your quick answers.

    I think that many of my problems are due to step 4 which caused me a lot of trouble.
    4 Configure the Hostname

    When I open : nano /etc/hosts by default I have these values that I did not touch :

    127.0.0.1 localhost

    ::1 localhost ip6-localhost ip6-loopback
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters

    127.0.1.1 debian.example.com
    127.0.1.1 ns3003340.ip-5-196-74.eu ns3003340

    I am on a dedicated server and not on a local network, how do I do this step?

    I will follow your instructions and then start from 0, after having received your answers on step 4.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Remove these two lines:

    127.0.1.1 debian.example.com
    127.0.1.1 ns3003340.ip-5-196-74.eu ns3003340


    and add:

    x.x.x.x ns3003340.ip-5-196-74.eu ns3003340

    where x.x.x.x is the real external IP of your server. This assumes that ns3003340.ip-5-196-74.eu is the real FQDN hostname of your server. if not, replace it with your real server hostname.
     
  7. Mickael

    Mickael New Member

    Here is the result of the default commands:
    [email protected]:~# hostname
    ns3003340
    [email protected]:~# hostname -f
    ns3003340.ip-5-196-74.eu

    nano /etc/hostname :
    ns3003340
    nano /etc/hosts :
    127.0.0.1 localhost

    ::1 localhost ip6-localhost ip6-loopback
    ff02::1 ip6-allnodes
    ff02::2 ip6-allouters

    127.0.1.1 debian.example.com
    127.0.1.1 ns3003340.ip-5-196-74.eu ns3003340

    I have a domain name that points to the server's ip address if it can help with configuration
     
  8. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    You did not remove the two lines till told you to remove.
    If you have a domain name and can use an FQDN you can use that FQDN as your hostname, but then you have to use that as hostname, hostname -f and in /etc/hosts file. If you plan to use this host as an e-mail server, consider what you can use as PTR record in name service (some info in tutorial linked to in my signature).
     
  9. Mickael

    Mickael New Member

    A correct configuration of the host file would therefore be :
    127.0.0.1 localhost

    ::1 localhost ip6-localhost ip6-loopback
    ff02::1 ip6-allnodes
    ff02::2 ip6-allouters

    5.196.74.210 ns3003340.ip-5-196-74.eu ns3003340
     
  10. Mickael

    Mickael New Member

    I followed the tutorial step by step and I have this error on mariadb

    [email protected]:~# systemctl daemon-reload
    [email protected]:~# systemctl restart mariadb
    Disclaimer : The drive file, source configuration file or mariadb.service repositories have changed on the disk. Run "systemctl daemon-reload" to reload the units.
    [email protected]:~# netstat -tap | grep mysql
    tcp6 0 0 [::]:mysql [::]:* LISTEN 16111/mysqld
     
  11. Mickael

    Mickael New Member

    The installation works, I was able to connect to my ISPCONFIG interface.
    I still have 2 questions that will not be in the right topic
    First of all, how to get an approved SSL certificate? It displays an error ...
    And then is it possible to put the interface in French?
     
  12. ahrasis

    ahrasis Well-Known Member

    If you want to obtain and use lets encrypt ssl certs for this server, use your own FQDN and not the one given by the provider since they may be a lot other servers that are using its subdomain as FQDN, or otherwise, you can only use a self-signed ssl certs.
     
  13. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    What interface?
    If you mean ISPConfig, then yes.
    If you wonder where to set that, it is in client settings, Language when Admin creates the user. User can change this him/herself in Tools tab, Password and Language. With a bit of effort you could have discovered these yourself.
     

Share This Page