apache oddity 2.0.7

Discussion in 'General' started by jnoble, Aug 17, 2005.

  1. jnoble

    jnoble New Member

    Hello, First off, Great job all!!

    second, my httpd is not serving anything except the default test page for fedora3, I have one reseller, one client, and one site.


    These are the errors I am seeing, I have tried all kinds of permission tricks, and no help


    16.08.2005 - 17:05:46 => WARN - WARNING: could not open file /etc/httpd/vhosts/Vhosts_ispconfig.conf
    16.08.2005 - 17:05:47 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 1182: WARNING: could not cp -fr /etc/httpd/vhosts/Vhosts_ispconfig.conf /etc/httpd/vhosts/Vhosts_ispconfig.conf~
    16.08.2005 - 17:05:47 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2328: WARNING: could not httpd -t &> /dev/null
    16.08.2005 - 17:05:47 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2334: httpd syntax seems to contain errors, reloading with old configuration
    16.08.2005 - 17:05:47 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2336: WARNING: could not mv -f /etc/httpd/vhosts/Vhosts_ispconfig.conf~ /etc/httpd/vhosts/Vhosts_ispconfig.conf

    ____________________

    at the end of the install, I see these msgs, probabaly the root of above:

    Connected successfully to MySQL server
    cp: omitting directory `/'

    Warning: fopen(/): failed to open stream: Is a directory in /root/james/install_ ispconfig/install.php on line 110

    Warning: fwrite(): supplied argument is not a valid stream resource in /root/jam es/install_ispconfig/install.php on line 111

    Warning: fclose(): supplied argument is not a valid stream resource in /root/jam es/install_ispconfig/install.php on line 112
    Restarting some services...
    Shutting down postfix: [ OK ]
    Starting postfix: [ OK ]
    Shutting down proftpd: [ OK ]
    Starting proftpd: [ OK ]
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    FreshClam is already running!
    ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.

    --------

    I had 2.0.7 and installed 2.0.8 over it, the end result of these errors is that my vhosts are not being written, nor accessed. anyone want to share a clue or two? I have been looking through the forums,and they have solved a few other issues so far, but I did not find this one.

    Thanks In Advance
    James
     
  2. falko

    falko Super Moderator

    Does /etc/httpd/vhosts/Vhosts_ispconfig.conf exist?

    You mean you had 2.0.6 and installed 2.0.7 over it. Was 2.0.6 working for you?
     
  3. domino

    domino New Member

    I didn't get an email notice that 2.08 was released already ;) . Anyway, my upgrade from 2.06 to 2.07 was flawless. Just a heads up.
     
  4. jnoble

    jnoble New Member

    getting better

    Hello, I was doing a fresh install of 2.0.7 and got the email about 2.0.8, so went straight to it. 2.0.7 was not working properly, most of which were fixed after upgrading.

    Im a little confused about how the Vhosts are supposed to be called. I thought there would be an include line in httpd.conf, but there is not one, and if I add one pointing to either
    /vhosts/Vhosts_ispconfig.conf
    or
    /etc/httpd/vhosts/Vhosts_ispconfig.conf

    it gives an error:

    Code:
    Starting httpd: Warning: DocumentRoot [/home/www/web3/web] does not exist
    Warning: DocumentRoot [/home/www/web5/web] does not exist
                                                               [FAILED]
    [root@server1 ~]# ls -la /home/www/web3/web
    total 40
    drwxrwxr-x  4 web3_sysop web3 4096 Aug 17 04:00 .
    drwxr-xr-x  8 web3_sysop web3 4096 Aug 17 04:00 ..
    drwxrwxr-x  2 web3_sysop web3 4096 Aug 16 12:38 error
    -rw-rw-r--  1 web3_sysop web3 1214 Aug 16 12:40 index.html
    drwxr-xr-x  2 web3_sysop web3 4096 Aug 17 04:00 stats
    [root@server1 ~]# ls -la /home/www/web5/web
    total 48
    drwxrwxr-x  4 root web5 4096 Aug 17 04:00 .
    drwxr-xr-x  8 root web5 4096 Aug 17 04:00 ..
    drwxrwxr-x  2 root web5 4096 Aug 16 14:02 error
    -rw-r--r--  1 root web5 1212 Aug 16 15:31 index.htm
    -rw-rw-r--  1 root web5 1212 Aug 17 10:13 index.html
    drwxr-xr-x  2 root web5 4096 Aug 17 04:00 stats
    [root@server1 ~]#
    
    There is def something wrong in permissions, but what is it?

    Thanks
    James
     
  5. falko

    falko Super Moderator

    It can also be in apache.conf, apache2.conf, ..., the file mentioned when you run
    Code:
    httpd -V
     
  6. jnoble

    jnoble New Member

    still odd bahavior install/apache

    Hello, and thanks again.

    I reinstalled fedora3 (as per guide) and installed ISPconfig (as per guide) after updating the zlib to the one from fedora4 the install seemed to go good, however, I did see these errors at the end again.

    Im not having the skill to track those down right away, anyone seen them on Fedora3?

    my httpd.conf appears to be just this one now:

    /etc/httpd/conf/httpd.conf

    It does not have an include at the end, nor does it look to have been modified.

    httpd -V gives me this:



    I have a copy of the server for backup (in vmware format) and am going to try fedora4 on the actual server today.

    Any one that can help, Id appriciate it.
     
  7. falko

    falko Super Moderator

  8. jnoble

    jnoble New Member

    resolved - sorta

    Hello, I moved to Fedora 4 and the install seems to have worked fine, im testing functions, and will let you all know in a new thread.

    Thanks

    James
     

Share This Page