apache not starting

Discussion in 'Server Operation' started by cruz, Jul 11, 2008.

  1. cruz

    cruz New Member

    I noticed in ispconfig, under managment services that web server is offline. themn I tried to restart it and get this
    HTML:
    server1:~# /etc/init.d/apache restart
    Forcing reload of web server (apache2)...grep: /etc/apache2/mods-enabled/php4.lo                         ad: No such file or directory
    grep: /etc/apache2/mods-enabled/php4.conf: No such file or directory
    grep: /etc/apache2/mods-enabled/php4.load: No such file or directory
    grep: /etc/apache2/mods-enabled/php4.conf: No such file or directory
    apache2: Syntax error on line 185 of /etc/apache2/apache2.conf: Could not open c                         onfiguration file /etc/apache2/mods-enabled/php4.load: No such file or directory
     failed!
    
    I went into the mod-enabled file and I see two files php4 conf and load, but they have red marks on them. Can some one please help me with this?
     
  2. topdog

    topdog Active Member HowtoForge Supporter

    Those are dead links, use ls -l to find there they are supposed to point.
     
  3. cruz

    cruz New Member

    thanks

    Thanks Topdog. I reloaded the server. That happened once before. What makes the links become dead? it was working just fine. I know there was more than that going on. When I went into ispconfig it was taking a long time to load. sometimes I would have to hit the stop on the browser for the icons to show up on the screen. I just figured I would reload the server because of both of those issues.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -la /etc/apache2/mods-available
    ?
     
  5. cruz

    cruz New Member

    reloaded

    I ended up reloading the server. Thanks for the reply :)
     

Share This Page