Apache not starting up after installing ispconfig3

Discussion in 'Installation/Configuration' started by jamesls, Apr 11, 2009.

  1. jamesls

    jamesls New Member

    Hi

    I'm using ubuntu 8.10
    I followed the perfect server for ubuntu 8.10 and it worked fine for a week
    I then installed the ispconfig 3 and now apache won't start it says

    [warn] namevirtualhost 192.168.0.100:8080 has no virtual hosts
    [warn] namevirtualhost 192.168.0.100:* has no virtual hosts
    [warn] namevirtualhost 192.168.0.100:80 has no virtual hosts

    [fail]

    I also think I'm missing some sub directories off /var/www/ I only have 3, webalizer, ispconfig, php-cgi-scripts
    Looking at some config files for apache they mention directiories like "client" and in an error file there's another one for vlogger ... I don't appear to have them.

    I installed the desktop version of ubuntu not the server version I hope that doesn't make a big difference.

    I'd apreciate any help
    James

    below is part of my apache error log

    [Fri Apr 10 19:47:29 2009] [warn] child process 14809 still did not exit, sending a SIGTERM
    [Fri Apr 10 19:47:29 2009] [warn] child process 14810 still did not exit, sending a SIGTERM
    [Fri Apr 10 19:47:29 2009] [warn] child process 14811 still did not exit, sending a SIGTERM
    [Fri Apr 10 19:47:31 2009] [notice] caught SIGTERM, shutting down
    [Fri Apr 10 21:03:18 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Fri Apr 10 21:03:36 2009] [notice] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Fri Apr 10 21:03:36 2009] [notice] mod_python: using mutex_directory /tmp
    [Fri Apr 10 21:03:36 2009] [notice] Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4.1 with Suhosin-Patch mod_python/3.3.1 Python/2.5.2 mod_ruby/1.2.6 Ruby/1.8.7(2008-08-11) mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
    [Fri Apr 10 21:57:34 2009] [warn] child process 5839 still did not exit, sending a SIGTERM
    [Fri Apr 10 21:57:34 2009] [warn] child process 5840 still did not exit, sending a SIGTERM
    [Fri Apr 10 21:57:34 2009] [warn] child process 5841 still did not exit, sending a SIGTERM
    [Fri Apr 10 21:57:34 2009] [warn] child process 5842 still did not exit, sending a SIGTERM
    [Fri Apr 10 21:57:34 2009] [warn] child process 5843 still did not exit, sending a SIGTERM
    [Fri Apr 10 21:57:36 2009] [warn] child process 5839 still did not exit, sending a SIGTERM
    [Fri Apr 10 21:57:36 2009] [warn] child process 5840 still did not exit, sending a SIGTERM
    [Fri Apr 10 21:57:36 2009] [warn] child process 5841 still did not exit, sending a SIGTERM
    [Fri Apr 10 21:57:36 2009] [warn] child process 5842 still did not exit, sending a SIGTERM
    [Fri Apr 10 21:57:36 2009] [warn] child process 5843 still did not exit, sending a SIGTERM
    [Fri Apr 10 21:57:38 2009] [warn] child process 5839 still did not exit, sending a SIGTERM
    [Fri Apr 10 21:57:38 2009] [warn] child process 5840 still did not exit, sending a SIGTERM
    [Fri Apr 10 21:57:38 2009] [warn] child process 5841 still did not exit, sending a SIGTERM
    [Fri Apr 10 21:57:38 2009] [warn] child process 5842 still did not exit, sending a SIGTERM
    [Fri Apr 10 21:57:38 2009] [warn] child process 5843 still did not exit, sending a SIGTERM
    [Fri Apr 10 21:57:40 2009] [error] child process 5839 still did not exit, sending a SIGKILL
    [Fri Apr 10 21:57:40 2009] [error] child process 5840 still did not exit, sending a SIGKILL
    [Fri Apr 10 21:57:40 2009] [error] child process 5841 still did not exit, sending a SIGKILL
    [Fri Apr 10 21:57:40 2009] [error] child process 5842 still did not exit, sending a SIGKILL
    [Fri Apr 10 21:57:40 2009] [error] child process 5843 still did not exit, sending a SIGKILL
    [Fri Apr 10 21:57:41 2009] [notice] caught SIGTERM, shutting down
    unable to start piped log program ' /usr/sbin/vlogger -s access.log -t "%Y%m%d-access.log" /var/log/ispconfig/httpd': No such file or directory
    Unable to open logs
    unable to start piped log program ' /usr/sbin/vlogger -s access.log -t "%Y%m%d-access.log" /var/log/ispconfig/httpd': No such file or directory
    Unable to open logs
    unable to start piped log program ' /usr/sbin/vlogger -s access.log -t "%Y%m%d-access.log" /var/log/ispconfig/httpd': No such file or directory
    Unable to open logs
    unable to start piped log program ' /usr/sbin/vlogger -s access.log -t "%Y%m%d-access.log" /var/log/ispconfig/httpd': No such file or directory
    Unable to open logs
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Which exact guide did you follow?
     
  3. jamesls

    jamesls New Member

    I followed The Perfect Server - Ubuntu Intrepid Ibex (Ubuntu 8.10)
    and installed ispconfig 3.0.11

    I followed the instructions in "install_ubuntu_8.10.txt" that came withthe ispconfig 3 package.
    When I say I followed them I carried out the the istructions listed below
    I didn't Change Document root to /var/www/apache2-default/ because I don't have a directory there.. Should there be one


    8) Install ISPConfig 3
    *******************************************************************************
    There are two possile scenarios a) or b), but not both:

    a) Installation of beta 3
    ___
    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3.0.0.9-rc2.tar.gz
    tar xvfz ISPConfig_3.0.0.9-rc2.tar.gz
    cd ispconfig3_install/install/
    ___

    after a)

    proceed with the ISPConfig installation. Now start the installation process by executing:
    ___
    php -q install.php
    ___

    The installer will configure all services like postfix, sasl, courier, etc. for you. A manual setup as required for ISPConfig 2 (perfect setup guides) is not nescessary. To login to the ISPConfig controlpanel, open the following URL in your browser (replace the IP to match your settings!):

    http://server1.mydomain.tld:8080/

    the default login is:

    user: admin
    password: admin

    In case you get a permission denied error from apache, please restart the apache webserver process.


    8) Further Configuration-Tips
    *******************************************************************************
    8.1) Apache
    *******************************************************************************
    edit /etc/apache2/sites-available/default
    change the first lines to match your system.

    Replace 0.0.0.0 with your IP.
    Change Document root to /var/www/apache2-default/
    This directory is now the standard-hompage for your Server.
    ###
    NameVirtualHost 0.0.0.0:80

    <VirtualHost 0.0.0.0:80>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www/apache2-default/

    ###
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    If you followed this guide:

    http://www.howtoforge.com/perfect-server-ubuntu-8.10-ispconfig-3

    then everything is installed and configured properly inc. ispconfig. the ispconfig installation instructions contain basically the same, so you dont have to follow them as configuring everything twice might break your setup.
     
  5. jamesls

    jamesls New Member

    mmmm oh dear

    Thats not the one I followed ..... Never mind I'm geting good at reinstalling linux.

    I had a glance at that "how to" and it is different... I'll go give it a try

    I think that solves my problem

    Many thanks

    James
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Most likely you followed the perfect server guide for ispconfig 2, if this was the case then it explains your problems. The perfect server guide for ispconfig 2 is not compatible with ispconfig 3 as ispconfig 3 uses completely different applications and a different setup.
     

Share This Page