apache not loading vhost on debian testing

Discussion in 'Installation/Configuration' started by commentator, Aug 11, 2013.

  1. commentator

    commentator Member

    testing a bit with debian testing branche.

    After upgrade to this testing branche ispconfig controlpanel is not available as the vhost files are not loaded after starting apache.
    When adding this to the config file to include also *.vhost files there is an error:
    AH00526: Syntax error on line 18 of /etc/apache2/sites-enabled/000-apps.vhost:
    Either all Options must start with + or -, or no Option may.
    Action 'configtest' failed.
    can fix this by adding the + or - to this line and the one in ispconfig host but after changing something in control the + or - are gone and the problem is there again.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which apache version do you have installed? The apache conig syntax in changed in 2.4, this new syntax is not supported yet. So dont use apache vesion 2.4 with ispconfig.
  3. commentator

    commentator Member

    yes it is Apache 2.4
  4. stef157

    stef157 Member

    For a new installation, how it's possible to manage this ?
    This will work or there will be a problem after the installation ?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    You can not use apache 2.4 with the current ispconfig releases as apache 2.4 is not supported yet. We will add support for apache 2.4 in future.

Share This Page