Apache httpd 2.4 support

Discussion in 'Feature Requests' started by iDen, Mar 14, 2013.

  1. iDen

    iDen New Member

    Any plans regarding support of httpd 2.4 in ISPconfig v 3.0.5.x ?
     
  2. till

    till Super Moderator

    Is there already a Linux distribution that ships with apache 2.4 as default?
     
  3. iDen

    iDen New Member

    There is distribution with 2.4 rpm compiled by me with provided spec.
    Syntax differs from 2.2 ...
    Fedora 18 has.
    RHELv7 is announced to be available this fall, it will have.
    So it was just question.
     
    Last edited: Mar 14, 2013
  4. till

    till Super Moderator

    We will add support for apache 2.4 off course, but I can not give you a date when it gets finished.
     
  5. SSullivan

    SSullivan New Member

    Hi Till,

    What happens if I install this, make the required changes (such as AUTH is different) and then later upgrade ISPconfig? Does ISPConfig re-install Apache 2.2?
     
  6. till

    till Super Moderator

    ISPConfig odes not install any software. If you change sourcecode of a software and install a update of that sotware, the update will overwrite your custom changes.
     
  7. iDen

    iDen New Member

    Wow wow !!!

    Just saw in Roadmap that you have added plans to support Apache 2.4 in next minor release.

    Does it mean that ISPconfig will support at least new mod_proxy_fcgi for better PHP-FPM integration?
    Help old FastCGI die :)

    Of course we understand that such additions will make release available not so soon.

     
  8. iDen

    iDen New Member

  9. till

    till Super Moderator

    For 3.0.5.4 we plan to support the same features that are available for apache 2.2 in ISPConfg, so basically we will add code to support the new config syntax. mod_proxy_fcgi is not on our roadmap yet. Feel free to make a feature request for it in the bugtracker, in case that there is no such requestyet (havent checked it).
     
  10. demofreak

    demofreak New Member

    Is it possible to "cherry-pick" the already completed task into an existing 3.0.5.3 installation?

    I had to upgrade an OpenSUSE 12.3 box, and in the next distro release 13.1 there's no Apache 2.2 available anymore.

    Thanks.
     
  11. till

    till Super Moderator

    No, thats not possible. But 3.0.5.4 will get released soon anyway. If OpenSuSE has a apache compat module like debian, then apache 2.4 should work with ispconfig 3.0.5.3 as well.
     
  12. demofreak

    demofreak New Member

    Fine. :)

    Not to my knowledge.
     
  13. till

    till Super Moderator

  14. demofreak

    demofreak New Member

    Indeed. It's compiled in statically. :)

    Code:
    idefix:~ # apache2ctl -M|grep access
     access_compat_module (static)
    
    Upgraded a OpenSUSE 12.3 box to 13.1 just now, and it seems to run smooth until now.

    Some "Options" directives had to be altered (all Options must have a + or - sign in front of it, or no option must have it, but not mixed), and "a2enmod socache_shmcb" was necessary. That's all.
     
: httpd

Share This Page