Apache failure to start due to SSL

Discussion in 'Server Operation' started by thedoc351, Jan 18, 2013.

  1. thedoc351

    thedoc351 New Member

    I have a site that demands a SSL cert. The cert expired so I used your guide to generate a new certificate then followed the guide to use RapidSSL. Now when I try to start apache I get domain.bundle does not exist or is empty. So after getting that I copied the new certs into a file called domain.bundle and tried again to start apache. Now I see this: Restarting web server: apache2 failed! Anyone's help is appreciated. I really need to get this site up and running again ASAP.
     
  2. thedoc351

    thedoc351 New Member

    more information

    I would like to add that this is ispconfig 3.4. The original certificate was a free one from comodo that was used. I did delete the certificate in ispconfig ssl directive and that is when this problem started.
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Did you replace Comodo's bundle certificate with the one from RapidSSL?
     
  4. thedoc351

    thedoc351 New Member

    Yes I followed your tutorial to the letter. Could you tell me how I might generate new self signed so that apache will start and I can start over?

    okay here is what I have done so far. I disabled ssl and apache started. If I enable ssl apache fails to start. I assume this is from an invalid cert. What is the procedure to create new certs and enable ssl once more? This is a debian Lenny install of ispconfig 3.4
     
    Last edited: Jan 19, 2013
  5. falko

    falko Super Moderator ISPConfig Developer

    Delete the cert in ISPConfig and create a new one.
     

Share This Page