apache fails to start vhosts messed up.

Discussion in 'Installation/Configuration' started by TheMaximumWeasel, Jul 21, 2007.

  1. TheMaximumWeasel

    TheMaximumWeasel New Member

    So after doing the perfect set-up for centos 5 I test apache and it was working. After that I installed ISPConfig created a website and was just browsing the admin panel when I found that the webserver wasn't running. I tried reverting back to the original httpd.conf then apache started via command line. When I removed the include vhosts line from the ispconfig httpd.conf apache started then when I removed all vhosts except for the localhost one apache started. So it must be a site problem. but after deleting part of a vhost then restarting apache, apache worked. Now for some reason when ispconfig starts apache it runs for about 10 seconds then stops but ispconfig never sees that it starts but when I run service httpd start via command line it runs fine and doesn't stop.


    PS: one thing I noticed is that httpd runs on multiple pid's but when it runs for the 10 seconds after starting it via ispconfig it only is running on one pid before service httpd status returns httpd is not running.

    httpd.conf: http://pastebin.ca/628489
    Vhosts_ispconfig.conf: http://pastebin.ca/628494
    ifconfig: http://pastebin.ca/628496
    ls -la /root/ispconfig: http://pastebin.ca/628497

    I need to get this server up asap so all help is welcome. Right now I am running some sites off a backup.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please add the websites in the apache configuration again and the run:

    httpd -t

    and post the output.

Share This Page