Apache failed no connection

Discussion in 'Server Operation' started by kadi, Aug 26, 2011.

  1. kadi

    kadi New Member

    sudo error no valid sources

    thanks to everybody and solved by formating and fresh install.
    Last edited: Aug 31, 2011
  2. zcworld

    zcworld New Member

    not sure what OS you are using but have an look at the /var/log/http/error_log
    you can tail -f <path-to/file>
    in one putty / console window and try to restart apache to see what its saying in the error log
    or just open it up with an text editior and see whats going on
    u have to go to the bottom of the file

    if cant get ur head around it try and reboot
    if you haven't done that
    and check to see if SELinux is running

    maybe that is part of the problem

    sorry i cant help more than that

    im away from my normal desktop and haven't looked at ispconfig in ages
  3. zcworld

    zcworld New Member

    ok thats evil

    try this
    log in as root and type in

    rm /var/run/httpd/httpd.pid

    and try to start up apache

    if still an no go try this as well
    mkdir -p /usr/local/ispconfig/interface/web
    mkdir -p /var/www/ispconfig/

    and try to start apache

    if still an no go
    check the httpd.conf file (/etc/httpd/conf/) i think
    and see what user / group apache is trying to run as

    and i think for the log apache_error and apache_log
    just rename them to like old_apache_error / old_apache_log
    and see if thats helps out

    besides that im out of things to try and say

    maybe your ISPConfig went to hell, thats all i can think of as well

    not sure what else to say or tell you to try

    thats all i can think of
    Last edited: Aug 27, 2011
  4. kadi

    kadi New Member

    Apache unable to connect

    hello again zcworld
    Centos 6.
    Thanks for your reply.
    i tried all and no results, could it be the firewall blocking it ? and if it is where can i find it ?
    and stop it ? i looked in alot of places in the system files and could not find a script to stop.
    i just was thinking may be the firewall blocking apache, but how to deal with that ?.
    Thanks again for your help
  5. zcworld

    zcworld New Member

    firewall would only block incoming connections to that port 80
    but the output saying that it can not bind to port 80

    but i take it you are trying to start apache up as an root (super user) account

    you need to be root to bind to the lower port range

    do you have an folder called "/var/log/httpd"
    and its owned by apache:apache

    do as root
    su -
    if not chown -R /var/log/httpd
    and chmod -R 775 /var/log/httpd
    /etc/init.d/httpd restart ( i think)
    /etc/init.d/apache restart ( one of them two /etc/init.d/ commands will start apache up)

    if still no go

    than try to look at the httpd.conf file and change it from port 80 to like 88 and try to restart apache
    if starts up than something is on port 80 and blocking that port

    try telnet localhost 80 to see if something is running and than netstat to see whats running on port 80 and stop it

    besides that im almost out
    Last edited: Aug 27, 2011
  6. eyeoncomputers

    eyeoncomputers New Member

    What is the output of /etc/init.d/httpd configtest
  7. kadi

    kadi New Member


    Thanks for your concern, i just got tired and format with a new installation
    but i appreciate your response and concern.

Share This Page