Apache error when making change

Discussion in 'ISPConfig 3 Priority Support' started by SpeedyB, May 5, 2015.

  1. SpeedyB

    SpeedyB Member HowtoForge Supporter

    Hello,

    When I make a change in ISPConfig on a website I get the following error:

    Code:
    05.05.2015-18:59 - WARNING - Apache did not restart after the configuration change for website domain.tld. Reverting the configuration. Saved non-working config as /etc/apache2/sites-available/domain.tld.vhost.err
    05.05.2015-18:59 - WARNING - Reason for Apache restart failure: Failed to get D-Bus connection: Unknown error -1
    finished.
    
    When I look at the differences between the host files I see the following:

    old:
    Code:
    <Directory /var/www/domain.tld>
            AllowOverride None
                    Order Deny,Allow
            Deny from all
            </Directory>
    
    New:
    Code:
    <Directory /var/www/domain.tld>
            AllowOverride None
                    Require all denied
            </Directory>
    
    I attached the 2 vhost files.

    At this moment it is not possible to change settings in ISPConfig for a website.

    Please help.

    It is a multiserver setup which is installed as Wheezie and upgraded to Jessie.

    Apache version is:
    Server version: Apache/2.4.10 (Debian)
    Server built: Mar 15 2015 09:51:43

    Regards,

    Bas
     

    Attached Files:

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The new file is ok, it is the apache 2.4 syntax. ISPConfig is not saving the file as apache fails during restart. But the new config is not the reason, the problem is the dbus error that you posted. Try to restart apache with unchanged config and google for this dbus error and fix it, saving new config files will work again as soon as apache can be restarted.
     
  3. SpeedyB

    SpeedyB Member HowtoForge Supporter

    It restarts without a problem.
    When I modify the settings is the current config and restart it also works, but with the .err vhost it doesn't :(
    Code:
    [email protected]:/var/www/# service apache2 restart
    [ ok ] Restarting web server: apache2.
    [email protected]:/var/www/#
    
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Hmm, ok. The config is fine for apache 2.4. Did you try to reboot the system? Is the system maybe not fully updated t jessie?

    when you comment out the line:

    Require all denied

    in the .err file, then it restarts?
     
  5. SpeedyB

    SpeedyB Member HowtoForge Supporter

    When I restart it manually after moving the .err file as .vhost it also restarts.
    It seems only from the server.sh that it is not restarting ?? It is strange..

    I rebooted the server, but I'll reboot it again and test again.

    Code:
    [email protected]:/etc/apache2/sites-available# cp domain.tld.vhost.err domain.tld.vhost
    [email protected]:/etc/apache2/sites-available# service apache2 restart
    [ ok ] Restarting web server: apache2.
    [email protected]:/etc/apache2/sites-available# cp domain.tld.vhost.working domain.tld.vhost
    [email protected]:/etc/apache2/sites-available# service apache2 restart
    [ ok ] Restarting web server: apache2.
    
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, mabe it is a problem with the init system then. Did you keeps sysv.init or switch to systemd?
     
  7. SpeedyB

    SpeedyB Member HowtoForge Supporter

    If the change was in the Perfect Server manual (for Wheezy) I changed, otherwise I didn't.

    What I noticed in the Server Config is on the FastCGI tab that the config syntax is on Old. Do I need to change that?
    Screenshot 2015-05-06 09.02.48.png
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    No, wheezy did not had systemd, systemd was introduced with jessie.

    You can set it to new, but I dobnt expect that this is the problem.
     
  9. SpeedyB

    SpeedyB Member HowtoForge Supporter

    I ran the configure services again (through the update.php) and now the issue seems disappeared...

    I'll update if it returns.
     

Share This Page