Apache Down and Wont Restart

Discussion in 'General' started by tellar, Dec 30, 2007.

  1. tellar

    tellar New Member

    After working for ages without problems everything is still working ispconfig is fine and online but Apache wont start

    I have tried the command through ssh

    [email protected]:/# /etc/init.d/httpd restart
    bash: /etc/init.d/httpd: No such file or directory
    [email protected]:/#

    where is httpd ?

    Are my sites gone?

    HELP!
     
  2. Hans

    Hans Moderator ISPConfig Developer

    Please try: /etc/init.d/apache2 restart
     
  3. tellar

    tellar New Member

    ok done that

    have run the command and apache tries to restart.

    apache gives the error that allow override is not allowed on line 368 in the virtualhost file

    have commented ot this line and in the other files now I get the message that there are no virual hosts
    "
    [Sun Dec 30 13:46:00 2007] [warn] NameVirtualHost "My IP" has no VirtualHosts"
     
  4. tellar

    tellar New Member

    httpd (no pid file) not running

    httpd (no pid file) not running

    this message is also being given

    apache is running but sites are not available
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    please run:

    httpd -t

    and post the error message.
     
  6. tellar

    tellar New Member

    Results

    [email protected]:/etc/apache2/vhosts# httpd -t
    [Sun Dec 30 17:04:27 2007] [warn] NameVirtualHost 80.69.93.79:80 has no VirtualHosts
    Syntax OK


    (I have made a new folder /vtmp and copied all files from hosts there then made a change in ispconfig site settings and duplicated the new ispconfighosts file as Vhosts)


    there is still access to the sites but apache starts
     
  7. tellar

    tellar New Member

    [problem solved]

    Ok it works again,

    with ispconfig open I deleted the files in /etc/apache2/vhosts

    mkdir /vtmp (make a new directory to store the backup files in)

    then copied all the files from /etc/apache2/vhosts there

    cp Vhosts /vtmp/Vhosts.bak
    cp vhosts /vtmp/Vhosts.bak

    I deleted the files in /etc/apache2/vhosts

    rm Vhosts
    rm vhosts

    then added # in one of the sites directives in the controll pannel for that site

    then removed it

    ispconfig writes a new virtual hosts file and it came back online
     

Share This Page