Apache doesn't work?

Discussion in 'Installation/Configuration' started by BlackTiger, Apr 15, 2008.

  1. BlackTiger

    BlackTiger New Member

    I just installed ISPconfig, and the installation worked fine. However, apache doesn't seem to work very well.
    It gave me an URL, and told me to change de default admin/admin but the url didn't work.

    I then tried to restart apache, but got:

    Code:
      [email protected]/root/ispconfig $ sudo httpd/bin/apachectl restart
    httpd/bin/apachectl restart: httpd not running, trying to start
    httpd/bin/apachectl restart: httpd started
    
    so It doesn't look like apache is running. Any idea what could be wrong? and, is there a way to reconfigure without recompiling everything?

    I'm on ubuntu 7.10
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    To restart the ispconfig apache, run:

    /etc/init.d/ispconfig_server restart

    If the URL did not work, then try the IP. Most likely its a dns problem that the url you entered is not resolvable from your client computer.
     
  3. webwork

    webwork New Member

    Check the Listen section in the Apache conf file

    What usually happens is that the wrong IP and or port are specified in the conf file, . It may be the following settings which are incorrect:
    as an example with a ficticious IP
    server = 192.145.56.77:80
    listen = 192.145.56.77:80
    listen *:80
    listen 80
    You can try commenting the server line out
    #server = 192.145.56.77:80
    Essentially the server has a conflict in which adapter is being listened to and/ or you have not assigned an ip for it to listen.
     
  4. webwork

    webwork New Member

    Also if the service shows it started

    Then the problem may be in the network adapter host setting. The host should be like serverxys and the domain like microsoft.com set at the adapter. When you go to ISP CONFIG the URL would then be http://serverxys.microsoft.com:81
     

Share This Page