Apache Directive for include_path problem

Discussion in 'Installation/Configuration' started by liggyman, Jun 18, 2009.

  1. liggyman

    liggyman New Member

    I'm hoping someone can help me out with this.

    I'm in the process of migrating an application to an ISPC3 server. For security reasons the includes directory is not located in the web folder, and was setup in the old httpd.conf file using:

    php_value include_path .:/path/to/sites/includes

    I have created the same directory and set the permissions and ownership to be identical to the other directories. I then uploaded the required files to this directory.

    After doing that I added the following to the sites Apache Directives form:
    php_value include_path .:/var/www/clients/client1/web1/includes

    This appears not to work. This is a part of the error message: Failed opening required 'header.php' (include_path='.:/usr/share/php:/usr/share/pear')

    I have tried to modify that line with single quote, double quotes, and using php_admin_value, with no change in behaviour.

    I have verified that the changes get applied to the:
    /etc/apache2/sites-enabled/{sitename}.vhost

    Simple diagram to show folder layout:

    /
    - includes
    - web


    Any help in getting this working is much appreciated. Thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which PHP method did you select for the website in ISPConfig?
     
  3. liggyman

    liggyman New Member

    I knew I'd miss something.

    I have SuPHP selected. I also have SuEXEC checked at the moment.

    Should I be trying another setting here?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Setting directives with php_value or php_admin_flag works only with mod_php. If you want to use suphp, then you can specify the directory for a dedicated php.ini instead:

    http://www.suphp.org/DocumentationView.html?file=apache/CONFIG

    .....

    suPHP_ConfigPath (expects a path name)

    This option tells mod_suphp which path to pass on to the PHP-interpreter
    (by setting the PHPRC environment variable).
    Do *NOT* refer to a file but to the directory the file resists in.

    E.g.: If you want to use "/path/to/server/config/php.ini", use
    "suPHP_ConfigPath /path/to/server/config".

    If you don't use this option, PHP will use its compiled in default path.

    ....
     
  5. liggyman

    liggyman New Member

    Sometimes the simplest things are overlooked.

    I probably should have come here for help on this before spending a few hours trying to track the fix down.

    Thanks!
     
  6. linuxbastard

    linuxbastard New Member

    should i create a new php.ini or just append additional directives?

    Hi Guys,

    Been on here straight for a few days now and I was looking for this specific control for one of my virtual host.

    Got an additional question though since am just starting out with different mods for php and want so much not to screw up my installation.

    Do I need to create the whole php.ini if I do this or would it be OK to just insert the additional directives I need?

    Thanks for any help.
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Are you referring to mod_php or suPHP?
     
  8. linuxbastard

    linuxbastard New Member

    suPHP for starters

    Hi Falko,

    What I really wanted to do is enable/include Zend Framework for a development vhost.

    I have a vhost on suPHP. I installed ZF in /opt/ZendFramework/current. And have modified this line on /etc/php5/apache2/php.ini and /etc/php5/cli:
    Code:
    [...]
    include_path = ".:/opt/ZendFramework/current/library:/usr/share/php5:/usr/share/pear"
    [...]
    
    That's where I'm stuck. What do I do so that my vhosts could use the library or run the zf command tool?

    Thanks for the reply and hope you can help.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to edit the /etc/php5/cgi and not the cli php.ini. cli is only for the commandline and not for cgi applications.
     

Share This Page