Apache default page instead of domain page.

Discussion in 'Installation/Configuration' started by Milen Karaganski, Aug 26, 2020.

  1. Milen Karaganski

    Milen Karaganski New Member

    Checked a few similar topics but couldn't find a solution. My second server (with apache only installed) and all domains open the default apache website. So:

    1. Attached is my htf_report. In the beginning, I have

    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine the server's IP address by ifconfig
    [INFO] OS version is Ubuntu 18.04.5 LTS
    [INFO] ISPConfig is installed.

    2. In SYSTEM > SERVER IP ADDRESSES I have both my servers and the corresponding internal IP
    3. Sites on the master server have * for IP and work well
    4. Following the above, I've changed the sites on the second server to point to its internal IP in website settings
    5. Both vhost had changed:
     [URL='']Virtual Server[/URL]
    Handles the name-based server merklin.xyz on address
    [B]Port[/B] 80 [B]Server Name[/B] merklin.xyz
    (not live yet due to nameservers change)
     [URL='']Virtual Server[/URL] Handles the name-based server softniverse.com on address
    [B]Port[/B] 80 [B]Server Name[/B] softniverse.com
    (you can try this domain to see the page it opens)
    Sites on master server for reference:

    6. Output for both hostname and hostname -f is "cp2.shhservice.com"
    7. On both servers in /etc/hosts I have (the second server has cp2.* instead of cp.*):
    Code:    localhost.localdomain    localhost
    ::1        localhost6.localdomain6    localhost6   cp.shhservice.com cp-shhservice-com cp.shhservice.com cp2.shshervice.com
    8. apachectl -S output:
    AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:73
    VirtualHost configuration:       is a NameVirtualHost
             default server merklin.xyz (/etc/apache2/sites-enabled/900-merklin.xyz.vhost:7)
             port 80 namevhost merklin.xyz (/etc/apache2/sites-enabled/900-merklin.xyz.vhost:7)
                     wild alias *.merklin.xyz
             port 80 namevhost softniverse.com (/etc/apache2/sites-enabled/900-softniverse.com.vhost:7)
                     wild alias *.softniverse.com
    *:8081                 cp2.shhservice.com (/etc/apache2/sites-enabled/000-apps.vhost:9)
    *:80                   cp2.shhservice.com (/etc/apache2/sites-enabled/000-default.conf:1)
    ServerRoot: "/etc/apache2"
    Main DocumentRoot: "/var/www/html"
    Main ErrorLog: "/var/log/apache2/error.log"
    Mutex proxy: using_defaults
    Mutex ssl-cache: using_defaults
    Mutex default: dir="/var/run/apache2/" mechanism=default
    Mutex fcgid-pipe: using_defaults
    Mutex authdigest-opaque: using_defaults
    Mutex watchdog-callback: using_defaults
    Mutex rewrite-map: using_defaults
    Mutex ssl-stapling-refresh: using_defaults
    Mutex authdigest-client: using_defaults
    Mutex fcgid-proctbl: using_defaults
    Mutex ssl-stapling: using_defaults
    PidFile: "/var/run/apache2/apache2.pid"
    Define: DUMP_VHOSTS
    Define: DUMP_RUN_CFG
    Define: MODSEC_2.5
    Define: MODSEC_2.9
    User: name="www-data" id=33
    Group: name="www-data" id=33
    9. Can't find any errors in LOG files. Changed manually the 000-default.conf to <VirtualHost> - nothing changes.

    Attached Files:

  2. Milen Karaganski

    Milen Karaganski New Member

    And just found out, that actually the domain URL opens default apache website on the master server!

Share This Page