Apache copy of a Virtual Hosts conf (all features enabled) for an example to work off

Discussion in 'Installation/Configuration' started by j.smith1981, Aug 12, 2010.

  1. j.smith1981

    j.smith1981 New Member

    Hi there,

    For some bizarre reason ISP Config 2 started making my server use loads of processing on my CPU, annoying isnt it?

    But I figured that maybe having someones (all features enabled so to speak), so I can comment those out and make them when I want to use them like mod ruby etc, disabled well.

    Would it be possible to see someones default config for apache using their own domain example, but without their domain name obviously, like for example, example.com or whatever?

    Just wanted to get a firm idea of how to set this up myself, as I have attempted a setup but its not working with 2 virtual hosts.

    Can someone reply with their config?

    I would really appreciate it,
    Jeremy.
     
  2. till

    till Super Moderator

    It is unlikely that this is caused by the apache vhost config. You can enable all features in all sites and this will not cause a higher load until you use this feature. E.g if you enabled ruby and the website contains no ruby files, then this will have no influence on performance.

    So to find the real reason for your problem, check with "top" which processes consume the cpu power.
     
  3. j.smith1981

    j.smith1981 New Member

    It doesnt show any processes that are using abnormally high values in processing.

    Just I am reluctant to bother installing it again if this is going to happen a 4th time.

    I did a clean install of centos 4.8, was fine until I installed ISP config 2, it then repeated using abnormally high processing.

    I then reinstalled centos without ISP config and will continue to use my own admin, just wanted to see someones config of a vhosts file to work out how to change what I have.

    Since I have not installed ISP config, it works perfectly.

    I know it is nothing to do with vhosts just wanted to see an example that works, since what I have tried to use for a name based vhost, doesnt appear to work, even when I set ServerName and ServerAlias to www.mydomain.com, doesnt want to work for some reason.
     
    Last edited: Aug 13, 2010
  4. falko

    falko Super Moderator

    Here's an example (but not with all features enabled):

    Code:
    <VirtualHost 1.2.3.4:80>
    SuexecUserGroup web1_user1 web1
    ServerName www.example.com:80
    ServerAdmin webmaster@example.com
    DocumentRoot /var/www/web1/web
    ServerAlias example.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias  /cgi-bin/ /var/www/web1/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web1/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    php_admin_flag safe_mode Off
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Alias /error/ "/var/www/web1/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    </VirtualHost>
     
  5. j.smith1981

    j.smith1981 New Member

    Ahh ok thats fine, thanks ever so much falko.

    Works fine when I put the top part in:

    NameVirtualHost *:80

    LOL, thanks ever so much for your reply, makes it so I can learn how to set one up should a problem arise when I dont have access to ISP config, i'd rather use my own setup anyhow, have it the way I want it you know?

    I really appreciate your reply,
    Jeremy
     

Share This Page