apache.conf missing

Discussion in 'Server Operation' started by idsinc, Jan 25, 2011.

  1. idsinc

    idsinc New Member

    It appears as though my apache.conf is missing from:

    /etc/squirrelmail/apache.conf

    That may be why I get an error when I tried to run:

    cd /etc/apache2/conf.d/
    ln -s ../../squirrelmail/apache.conf squirrelmail.conf
    /etc/init.d/apache2 reload


    Not sure what the deal is. How do I get the apache.conf , and then put back in /etc/squirrelmail/

    Thanx in advance.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    You can use this one (that's the default apache.conf from a Debian Lenny server):

    Code:
    Alias /squirrelmail /usr/share/squirrelmail
    
    <Directory /usr/share/squirrelmail>
      Options Indexes FollowSymLinks
      <IfModule mod_php4.c>
        php_flag register_globals off
      </IfModule>
      <IfModule mod_php5.c>
        php_flag register_globals off
      </IfModule>
      <IfModule mod_dir.c>
        DirectoryIndex index.php
      </IfModule>
    
      # access to configtest is limited by default to prevent information leak
      <Files configtest.php>
        order deny,allow
        deny from all
        allow from 127.0.0.1
      </Files>
    </Directory>
    
    # users will prefer a simple URL like http://webmail.example.com
    #<VirtualHost 1.2.3.4>
    #  DocumentRoot /usr/share/squirrelmail
    #  ServerName webmail.example.com
    #</VirtualHost>
    
    # redirect to https when available (thanks [email protected])
    #
    #  Note: There are multiple ways to do this, and which one is suitable for
    #  your site's configuration depends. Consult the apache documentation if
    #  you're unsure, as this example might not work everywhere.
    #
    #<IfModule mod_rewrite.c>
    #  <IfModule mod_ssl.c>
    #    <Location /squirrelmail>
    #      RewriteEngine on
    #      RewriteCond %{HTTPS} !^on$ [NC]
    #      RewriteRule . https://%{HTTP_HOST}%{REQUEST_URI}  [L]
    #    </Location>
    #  </IfModule>
    #</IfModule>
     
  3. idsinc

    idsinc New Member

    That was very helpful.

    so I ran the rest of the commands:


    I finished with these results:
    after ln the result was:
    ln: creating symbolic link 'squirrelmail.conf' :file exists

    after /etc/init.d.. the result was:
    [OK]

    Is this what I should have expected? I'm asking because I ran this once already, with failed results. Now that I have the apache.conf file it doesn't say file not found. :)
     
  4. idsinc

    idsinc New Member

    squirrelmail login issues

    I moved on to the next instructions (from the LAN):

    "http://www.example.com/squirrelmail"
    and
    "http://server1.example.com:8080/squirrelmail"

    but neither works

    I did type in :

    "http://192.168.0.100:8080/squirrelmail/src/login.php"

    and i get access....

    What have I done wrong?:confused:
     
  5. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -la /etc/apache2/conf.d/
    ?
     
  6. alleks

    alleks Member

    what's the output on

    Code:
    tail -f /var/log/syslog
    when you do a

    Code:
    /etc/init.d/apache2 restart 
    ?
     
  7. idsinc

    idsinc New Member

    I have to hand type this, because my server doesn't have a desktop... I don't know what to install with ubuntu 10.10, because there weren't any instructions to do this. :(

    Wish I could copy and paste... have to go to server then back to pc ... lol
     
  8. idsinc

    idsinc New Member

    restart



    I wonder if this has something to to with the OpenVZ confusion I had in another post.
    http://www.howtoforge.com/forums/showthread.php?t=51101

    :confused:
     
    Last edited: Jan 26, 2011
  9. falko

    falko Super Moderator ISPConfig Developer

    Does
    Code:
    cat /etc/apache2/conf.d/squirrelmail.conf
    show what I posted in post #2?
     
  10. idsinc

    idsinc New Member

    cat /etc/apache2/conf.d/squirrelmail.conf

    I added one line, from the tutorial, second line.
     
  11. alleks

    alleks Member

    Are you using ISPConfig?
     
  12. idsinc

    idsinc New Member

    ISPConfig3

    Yes, ISPConfig3

    I can type in the IP address to the server, and the ISPConfig GUI pops up. I can login and change information.

    I can also type in the IP address and get squirrelmail.

    I can't access either one of these with the name of the server though.

    For example, if I type in server1.<mydomain>.com I get timed out connection.
    I used this installation: http://www.howtoforge.com/perfect-server-ubuntu-10.10-maverick-meerkat-ispconfig-3
     
  13. alleks

    alleks Member

    judging by your squirrelmail.conf you have to access this way

    http://domain.com/webmail and not http://webmail.domain.com

    BTW, check this with your actual one in each website's Options->open_basedir line to see if it matches

    Code:
    Now go to the PHP open_basedir field on the Options tab of your web site in ISPConfig and add the directories /usr/share/squirrelmail and /etc/squirrelmail (that's the directory where SquirrelMail's configuration is stored) to the line
    
     
    Last edited: Jan 27, 2011
  14. idsinc

    idsinc New Member

    Okay, it now looks like this:
    Of course domain would be my real domain name. I changed it here for privacy purposes.

    If type in http://192.168.0.100:8080/ and I get the IPConfig login page.
    If I type in http://192.168.0.100/src/login.php I get the SquirrelMail login page.

    I type in the server name http://server1.domain.com and I get "Firefox can't establish a connection to the server at server1.domain.com."

    I was told that I need to do port forwarding inside the PK5000, but I know I selected port forwarding at the Qwest.net site. Should I do this in both places (Qwest account online and inside the modem)? http://www.actiontec.com/howto/

    Another thing, when I set up the website, i didn't set up a client... looks like client0 is the server... is it suppose to be?
     
    Last edited: Jan 27, 2011
  15. idsinc

    idsinc New Member

    RE-installing

    I started a re-install, just to make sure it was done right... started a new thread.

    Let me see if the install is bad, otherwise I could be spending months on this.

    THANX ALL!!:D
     

Share This Page