apache cannot start after creating a new site

Discussion in 'General' started by orasis, Sep 18, 2010.

  1. orasis

    orasis Member

    I made a new site yesterday with all default settings, didn't touch anything except I created a db for it to mess with some old db I had etc.

    today I run ubuntu again and apache won't start
    I run:
    /etc/init.d/apache2 start

    and get:

    Code:
     * Starting web server apache2                                                                                                                                                                                    Warning: DocumentRoot [/var/www/example.bounceme.net/web] does not exist
    Syntax error on line 54 of /etc/apache2/sites-enabled/example.bounceme.net.vhost:
    can't get fastcgi file info: /var/www/php-fcgi-scripts/web2/.php-fcgi-starter(/var/www/php-fcgi-scripts/web2/.php-fcgi-starter), errno: 2
                                                                                                                                                                                                               [fail]


    contents of example.bounceme.net.vhost are:

    Code:
    <Directory /var/www/example.bounceme.net>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <VirtualHost *:80>
          DocumentRoot /var/www/example.bounceme.net/web
      
        ServerName example.bounceme.net
        ServerAdmin webmaster@example.bounceme.net
    
        ErrorLog /var/log/ispconfig/httpd/example.bounceme.net/error.log
    
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
        
        <Directory /var/www/example.bounceme.net/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
        <Directory /var/www/clients/client3/web2/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    
        # Clear PHP settings of this website
        <FilesMatch "\.ph(p3?|tml)$">
            SetHandler None
        </FilesMatch>
        # php as fast-cgi enabled
        <IfModule mod_fcgid.c>
          # SocketPath /tmp/fcgid_sock/
          IdleTimeout 3600
          ProcessLifeTime 7200
          # MaxProcessCount 1000
          DefaultMinClassProcessCount 3
          DefaultMaxClassProcessCount 100
          IPCConnectTimeout 8
          IPCCommTimeout 360
          BusyTimeout 300
        </IfModule>
        <Directory /var/www/example.bounceme.net/web>
            AddHandler fcgid-script .php .php3 .php4 .php5
            FCGIWrapper /var/www/php-fcgi-scripts/web2/.php-fcgi-starter .php
            Options +ExecCGI
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
        <Directory /var/www/clients/client3/web2/web>
            AddHandler fcgid-script .php .php3 .php4 .php5
            FCGIWrapper /var/www/php-fcgi-scripts/web2/.php-fcgi-starter .php
            Options +ExecCGI
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    
        # add support for apache mpm_itk
        <IfModule mpm_itk_module>
          AssignUserId web2 client3
        </IfModule>
    
    
    </VirtualHost>
    
    
    

    any help please ? I am noob and only solution for me without a help will be to reinstall server ... much mess !
    any help appreciated
     
    Last edited: Sep 21, 2010
  2. orasis

    orasis Member

    very nice

    guess what. I reinstalled the server all from scratch.
    created a new site, made a db and an ftp user for it.

    all connected fine except ftp user.

    so I restarted computer.
    same result as above but with web1 this time.

    it was working perfect. go NO IDEA what went wrong with it....

    edit: I am following this step by step and doing it all perfect:
    http://www.howtoforge.com/perfect-server-ubuntu-9.10-ispconfig-3


    the exact msg I get on terminal after apache restart is this:

    * Restarting web server apache2
    Warning: DocumentRoot [/var/www/example.bounceme.net/web] does not exist
    apache2: bad user name web1
     
    Last edited: Sep 21, 2010
  3. orasis

    orasis Member

    well I am reinstalling again (HAPPY HOURS !!)

    some comments I would like you to clear for me if possible,
    I always get stuck at this point on this page:
    The Perfect Server - Ubuntu 9.10 [ISPConfig 3] - Page 4
    Next we install maildrop as follows:

    update-alternatives --remove-all maildir.5
    update-alternatives --remove-all maildirquota.7

    I get the this on terminal:
    update-alternatives: error: no alternatives for maildir.5.

    so searching for this I found this topic:
    http://www.howtoforge.com/forums/showthread.php?t=43518

    .. and this rsd-17 guy suggests to do place them like this that doesn't give back an error so this is what I do:

    update-alternatives --remove-all maildir.5.gz
    update-alternatives --remove-all maildirquota.7.gz

    hope this is not what causes the mess !
     
  4. till

    till Super Moderator

    As you reinstalled the server, we are not able to help you with fixing the problem.
     
  5. orasis

    orasis Member

    sure............................
     
  6. till

    till Super Moderator

    How shall we able to help you when you remove the files that caused the problem. You are really funny. ;)

    If your car is not working and you go to a garage and ask them what the problem is. They tell you to show them the car and then you say, oh, you want to see my car. I dont have it anymore....
     
  7. orasis

    orasis Member

    of course this is absolutely logical, of course I know that, but thanks for explaining.

    All I mean is, I got no idea how it happened. Now it works because I didn't touch the php.ini files yet.

    When it comes to this moment I think the problem will come back !
     
  8. till

    till Super Moderator

    You have not mentioned in your prior posts that the problems started after you changed a php.ini file. If you say what you changed in the php.ini, we might be able to tell you why it caused that problemand how to solve it.
     
  9. orasis

    orasis Member

    I agree, but now, cause when it happened I didn't know such changes can screw it,
    All I had changed was these:

    /etc/php5/cgi/
    /etc/php5/apache2/
    /etc/php5/cli/

    changes:
    display_errors = Off
    disable_functions = show_source, system, shell_exec, passthru, exec, phpinfo, popen, proc_open
    allow_url_fopen = Off
    memory_limit = 64M
    upload_max_filesize = 50M
    post_max_size = 64M
    max_execution_time = 300
    session.gc_maxlifetime = 10000


    make ftpd show hidden files:
    echo "yes" > /etc/pure-ftpd/conf/DisplayDotFiles


    you think those could affect ?
     
  10. till

    till Super Moderator

    The problem was that you disabled system, shell_exec, passthru, exec, popen, proc_open for cli-php. ISPConfig is a php script and if you disable exec for commandline scripts, then you disable the ability that ispconfig can configure your server. Disabling exec for php-cli is not nescessary as it is already a commandline script itself.
     
  11. orasis

    orasis Member

    thanks till, this was it then, I see.

    .. this means I will have to find a way to alter php.ini per site. Must be somewhere in the forum I guess.
     
  12. bat

    bat New Member

    i have thesame trouble, but nothing cant do with that...
    Warning: DocumentRoot [/var/www/user/data/www/2sport.ru] does not exist
    apache2: bad user name
    trying to find some in srv:/etc/init.d... but still apache is not working (((
     
  13. till

    till Super Moderator

    Are you really using ispconfig 3? The path /var/www/user/data/www/2sport.ru is not a default ispconfig path.
     
  14. bat

    bat New Member

    actually im using not ISPconfig, but ISPManager pro, but is no point because it doesnt work without apache, so i legged by SHH to try fix it
     
  15. till

    till Super Moderator

    1) This is the forum of the Software ISPConfig.
    2) This thread is about ISPConfig on apache servers

    So yes, it is the point if you use ispconfig or not as your issue is caused by your controlpanel and ispmanager and ispconfig are not related at all.

    Back to your problem:

    You will have to find the place were ispmanager writes the vhost configuration for the websites and remove the vhost with the document root /var/www/user/data/www/2sport.ru
     
  16. bat

    bat New Member

    i know about that, but only that topic helped me to fix my problem :)
    and thanks for your assitment and understanding anyway.
     

Share This Page