Apache and perl.conf error

Discussion in 'Server Operation' started by nenad, Dec 2, 2005.

  1. nenad

    nenad ISPConfig Developer

    Apache won't start due to following error:

    Everything worked fine until I installed RRDTool.
    Actually even then everyhting worked OK, untill I re-created server certificate with ISPConfig.

    BTW I have a problem with apt-get too:


    HELP!!! :eek:
     
  2. nenad

    nenad ISPConfig Developer

    If I uncomment that line then I got:

     
  3. nenad

    nenad ISPConfig Developer

    OK,

    I uncomented line, and I added new user in ISPConfig to make it reload config file.

    Now httpd runs.

    Is there any command to force ISPConfig server to reload config file?

    So, in one hand problem resolved, but in other hand it seems that I don't have internal interpretation of perl withi apache (which makes scripts runs faster) ?
     
  4. till

    till Super Moderator

    You dont have to add a new user in ispconfig to restart the httpd.

    Go to Management > Server > Services. Select web Server restart and hit save.
     
  5. nenad

    nenad ISPConfig Developer

    I restart httpd through shell with "service httpd restart".

    Question is how to force ISPConfig to reload configuration file?

    Falco told me in another thread that I have to change passw. add user etc. to make it reload ISP config file
     
  6. till

    till Super Moderator

    ISPConfig does not reload config files at all. If you mean that you want ISPConfig to rewrite the config file, you will have to add or cahnge a website to let ISPConfig rewrite the vhost configuration.
     
  7. nenad

    nenad ISPConfig Developer


    OK. I found solution.

    I done this:
    -------------------------------------------------------------------
    rpm -Uvh http://ftp.freshrpms.net/pub/freshr...elease/freshrpms-release-1-1.fc.fr.noarch.rpm
    yum update
    -------------------------------------------------------------------
    Then new Perl 5.8 ...etc. was installed altogether with depecies.
    Then I uncommented again the line that was troublemaker in /etc/httpd/conf.d/perl.conf
    and then I restarted httpd (service httpd restart)

    Now everything works fine.

    Note that new Perl-5.8... (whatever) was not avaiable in apt-get packages
    It's a kind of bug in previous Perl package. Who want to find out more please use Google
     
    Last edited: Dec 3, 2005
  8. nenad

    nenad ISPConfig Developer

    yes, that's what I meant.

    Is there a shell command to force ISPConfig server to reload config file?
    Or is it reloaded if service ISPConfig isrestarted?
     
  9. nenad

    nenad ISPConfig Developer


    How to resolve this?

    I am using YUM, so I don't know anything about apt-get.
    In yum there is yum search *package* so I can find exact name of package that I want to install.

    How do I do that with apt-get ?
     
  10. till

    till Super Moderator

    ISPConfig does not reload config files at all!

    If it does not reload config files at all, there cant be a shell command for a non existing function ;)

    Config files are loaded or reloaded by daemons like httpd, postfiix, bind, proftpd. You will have to restart the corresponding service to get the config files reloaded.
     
  11. nenad

    nenad ISPConfig Developer

    OK, ok...

    I tought that there is maybie some "ispconfig.conf" file which can be reloaded.:rolleyes:


    P.S. what should I do about apt-get? Help? Please?
     
  12. falko

    falko Super Moderator

    Code:
    apt-cache search <package>
     

Share This Page